TAZ4 Y-Axis won't move backwards?

Well, this is an odd one. My Y-axis won’t move backwards (towards the endstop). It seems to always think the endstop is triggered. I’ve tried disconnecting the physical endstop, using the X-axis endstop (briefly) in place of the Y endstop, reloading the firmware… nothing seems to work.

Is my RAMBo dead? All the other axes work fine, it’s just the Y axis that refuses.

Maybe I’ll try using the Y-max pins instead (for a Y-min).

Yeah, something’s gone wrong with my Y-min pin (pin 11). Swapping the Y-Max and Y-min endstop pins, and plugging the Y-min endstop into the Y-Max port, fixes the problem. Seems to me like Pin 11 got fried somehow.


When you first power up your printer, it is going to consider the position of the toolhead and bed as its “minimum” position. The firmware will prevent your machine from moving lower than 0 in any axis. (No negative movements) In order to reset the minimum position, please home all axis through USB of your preferred program, or through the LCD screen. This will allow full movement of all three axis.

Please give it a try, and let us know how it goes!

Yes Brent, I know that - not a newbie here. This problem began (or at least, I noticed it) when I ran my start Gcode on a print:

G28 X0 Y0;
G29 P5;

The Bed would never actually home to 0 - and during the G29 command, would move forward as though it had homed. It was acting as if the Y-Min Endstop was being held down at all times - so any forward move (say, to +5.00Y) would then immediately become ) again.

I would take a video but I jiggered the firmware to use a different pin for the endstop, which seems to have fixed the issue, and I don’t want to re-flash it and switch the wiring back.