Unable to connect to my new Taz 3 Printer

Just bought the new Lulzbot Taz 3 printer from you guys… I am so excited, but… I am encountering a problem. I installed the pronterface software and am running it from src. The serial device /dev/ttyACM0 is showing up on my Suse Linux Box just fine… I have the permissions to it as I am in the dialout group. I do a lot of project with USB/Serial devices so I am no stranger there. The pronterface software when I click connect just says “Connecting…”. It never connects. I see no errors in the linux messages log so I am beginning to get suspicious. Any ideas on trouble shooting the connection?

Alright… I followed the instructions and also hooked this thing up to a windows box with the exact same outcome of pronterface unable to connect the taz 3.

On the windows installation, did the driver installation see the hardware, and does device manager see a device hanging off Com port 4 when it’s plugged in? Also when you say windows, what version of windows are we talking? Specifically Not Windows 8?

Yes… A Com 4 port is available with the right driver when it is plugged in in the device manager. It’s windows 7.

On my OpenSuse 12 box (my preferred platform and what I tried first) the behavior is exactly the same… a serial port dev becomes available as soon as the taz 3 is plugged in.

The pronterface software sees the correct port on both windows and Suse… You press connect. It states in the output…


and then nothing… it just sits their happily with no error or additional output until I interrupt it.

Have you tried Repetier host instead? It gives you additional error message repeating and configuration options if nothing else. Assuming the board is powered correctly, plugged in correctly and the driver installed right it certainly should just connect. Potentially a loose connection on the board from shipping? If you can’t get it working, it should be under warranty still, so call customer service and have them get you taken care of if you can’t get it to connect.

Also, if you haven’t tried this already, try a different shorter USB cable and ensure you are going to a direct motherboard backplate port, and not via a front input panel or USB hub.

Haven’t tried Repetier software… didn’t know about that… I can… Is it pretty much the same as the other stuff?

I looked for some loose connections inside the black box on the side… everything seemed snug. One of the ribbon cables on the back of the lcd was a little loose but I had already noticed that and tried it. After it failed the first time on a usb hub, I tried connecting it directly to my laptop. No dice. My 4 and 8 year old were so sad. :frowning:

When is customer service open?

Try the Repetier software… after pressing connect… It acts like it is connected… If I press Home X though nothing happens… I am new to this but I am pretty sure that it should “home” the printer on the x axis if I not mistaken… It just states “9 Command Waiting” doesn’t seem like the commands are getting there unless their is something else I am suppose to be doing.

The unit sounds like it has a bad USB connection on the RAMBo. Email support@lulzbot.com and we’ll get you a replacement machine.


sounds like they’ll be able to get you all fixed up. To answer your other question though, repetier is basically prointerface, with extra features and a better interface in my opinion. Aside from that, same stuff. Having slicer built into it is handy though too.