Can't connect to TAZ 3 though USB.

I’ve had this problem for a long time and now I’d really like to use it.

When attempting to connect from any device/software it never goes through. Pronterface just displays “Connecting…” forever, Repetier gives up after trying all Baudrates, etc.

I know my COM port is correct because everytime I try to connect the printer software resets, on that point, is resetting normal or is that my issue?

Any help is greatly appreciated, thanks!

with repetier host, you may find that you can’t connect via USB unless you remove the SD card from its slot in the LCD.

Prointerface should connect up just fine. It does cause a reset when it connects, that is normal. Once it does it should respond to control inputs. If its resetting but then not responding to inputs, you have either the baud rate settings incorrect or the protocal setttings

You can also use Cura with the Taz 3 as well if you want. The Taz 3 rambo board is the same version as that in the Taz 6.

Thanks for the reply, the issue occurs regardless of whether the sd card is in or not, but I’ll keep it out for now. Just to note the printer works perfectly through the on-board controls and an sd card.

I cannot connect through any software I’ve tried, including both Cura and the Arduino IDE. I have Cura set to AUTO for the Baudrate which goes through all options before cancelling. Is there any way I can determine the baudrate or could it not be on of the options?

I am still running the firmware from stock which is Marlin 2013 Q4. I attempted to reflash newer firmware but since Ardunio cannot connect it doesn’t go through. Manually updating the driver doesn’t seem to help. Is it possible/a good idea to completely reset the board and attempt to install the firmware from scratch?

Try setting the baud rate to 115200 . If that doesn’t do the trick via prointerface or Arduino IDE, i’d try a different USB cable. If it still doesn’t work, I’d try a different computer, also make sure UAC is off. It is possible that the USB port on the rambo board itself is damaged. THe fix is replacing the Rambo board. You can source refurbished ones from or new ones from either lulzbot or directly from ultimachine .