Use only one extruder of Dual Extruder v2

Have been using my TAZ 5 off and on since December. Last weekend, I upgraded to the Dual Extruder v2. I am currently working my way through figuring out all the Cura settings, including creating my own profile by modifying the three that are there, and just getting good prints.

I would like to do a standard one filament print, but I would rather not go through uninstalling the dual extruder and reinstalling the single extruder. Is there a way through settings to tell it to only use the back (T0) extruder?

Do you really want the extra weight of the dual extruder for a single filament print? The extra mass will require you to slow the tool head speed down to accommodate the extra weight (weight that you aren’t even using). Basically you will have to print at a slower speed to get the same results that you would with a single extruder.

Swapping a tool head is 1 screw, takes about 30 seconds. The longest part is just recalibrating your Z offset.

I print with just T0 all the time… at speeds of 90mm/s. Its fine. T0 is close enough to the gantry that the extra mass isn’t an issue. Yes, its tougher on the steppers, but they can handle it… haven’t had one fail yet.

I use S3D as a slicer, but I believe in Cura just load up the model. Make sure its using the right tool (green model), turn off all the dual extruder features (prime tower, ooze shield). Set T0 to the right temp and T0 to 0C.

Printing with T0… means no switching toolheads, and everything is level and at the right height. Total time: 0.

Thank you for the replies.

moejt,
Doesn’t switching back to the single extruder also mean removing the extra cable and flashing the firmware, or can the extra cable stay in place? I don’t want to have to go through cutting all the tie straps and prying the cable out of the clip at the top of the tool head bracket if I can avoid it.

kcchen_00,
Do you mean to set T1 to 0-degrees?

0C (Celsius), yes. :slight_smile: This will conserve energy and not burn up the filament in T1.

To answer your other question, you don’t need to remove the cable for the second extruder if not in use. Just leave it in and connect the right connector to the single extruder.

kcchen_00,

Thank you for the follow up. Unfortunately, it looks like I will be switching back and forth between heads. I’m probably doing something wrong, but it throw a communication area every time I hit Print when I try to set all the settings the way I think I should for a single extruder print.

By the way, since you seem to have experience with the dual, do you have any experience using nGen with a support material? With the exception of not offering Brown, I like their color quality a lot better than the other filament options. I have both PVA and HIPS handy, but I thought I’d ask if you had a preference (or anyone else out there for that matter).

Thank you again.

Hmm… It sounds like you’re selecting the TAZ Single extruder machine type. Stick with the the TAZ Dual Extruder machine type. If the object is colored green then it will print with T0. Objects in red will print with T1.

If that’s what you’re doing, upload the gcode. I can run it through the gcode simulator in S3D.

Regarding the nGen, I haven’t worked with the filament. Since the recommended extrusion temp is 230C, I’d probably go with HIPS as the dissolvable support material.

Anyone used just one extruder on the Taz 6? None of these solutions seem to work for me.

According to tech support it can be done without on the Taz 6, however you will need to copy the start2.gcode into the start.gcode and also copy the end2.gcode into the end.gcode. I would probably also modify the code so that it doesn’t heat up the second extruder at all, but that’s up to you. I haven’t actually tried this yet because I haven’t had time. I may try it this weekend.

I have a number of times. I basically do what is recommended by the Support group on using the start and end code for the single and then make sure I do not heat up the front extruder in the slicing software. If you are trying to use the front and not the back one then you have to use both in the start and end code as the back is the one used for probing and it needs heated to clear any filament on the tip of the nozzle. Then after the leveling routine you can probably turn the unused back extruder off to prevent cooking the material in the nozzle.

kcchen_00,

I had the machine configured for the dual extruder only. Everything worked fine, but every time I would click Print, I would get an error saying that communication had been lost due to a loss of power or an unplugged USB cable, which was odd, because it had no problem sending temperature information back and forth. I’m sure this was some setting I was missing, but it was enough for me to uninstall the dual for the time being. I have some prints that will work with a single extruder that I need to get done. I’ll have to reinstall and try again this weekend.

wibby,

I’ll have to try this code swap. I didn’t know about this method. Maybe that will get me past the communication error.


On a somewhat related note, maybe someone can give me a hint on what I believe is a filament issue.

For my first support material print, I used a combination of the ABS/ABS and PLA/PVA settings to come up with a ABS/PVA setting. I used the recommended settings for the support. I wound up with a lot of sag and bulge in the lower half of my print, which went up straight a short distance and the went out to a wider diameter with a small straight horizontal stretch and then a filleted horizontal stretch before going vertical again (picture the lower part of the head on a LEGO minifigure). It seems to me that the ABS was not maintaining its shape and sagging out into the gap between it and the PVA.

After reading some posts on this forum, I changed the support gaps to 0 and increased the infill to 100%. I wound up cancelling very quickly, because the PVA appeared to be priting over the first layer of ABS, instead of jumping over it, and mounding up in areas, causing the extruder to increasingly move up and down as it traveled over the mounded filament. This is when I decided to pull the dual and go back to the single to get some work done.

I’m new enough to this that I don’t really know if this is a settings issue, a filament issue, or something like having the nozzles too low to the bed. I could get doubled-up paper underneath each tip, but they were a little tighter to the paper than I normally set the single extruder. I know pictures would help, but I didn’t think to take any at the time.

Based on this description though, does anyone have any suggestions"?

Thank you in advance.

I am trying to use just the front, flexible, extruder on my Taz 6. How do I tell Cura that I am just using this extruder? When I load two models in for dual extrusion and merge, the first model loaded in prints from the back extruder. But if I am just printing with the front extruder, how do I do this? How does it know I am not trying to just use the back extruder?

If I remember correctly Cura does not handle dual extruders(single extruder) well you will have to add the manual T0/T1 into the generated gcode file.

But I do not use Cura in my day to day work. So I am not up on Cura internals.

Ya, you’re right, thanks! I just added a T1 at the end of my Gcode (and removed the line that retracts T1 at the beginning) and that did the trick. The base profile I was building off of was ABS/NinjaFlex and it seems like it is printing too fast because the extruder skips.

Are materials printed at different speeds in dual material profiles? If so, I can’t seem to find where to change each individual material/extruder print speed.

Looking at that profile it uses a quick Ninjaflex speed, 17 MM/s is a little faster than I normally print ninjaflex at. I think they use a print speed of the slowest material print speed like Ninjaflex as ABS can be printed slow but ninjaflex will not melt very fast. So if you are skipping, lower the print speed in the Cura settings a little.

Could you further explain that? I’m a new user and I am trying to understand it well so I don’t damage the printer or the new dual nozzle tool head I got.
I want to print with only Ninjaflex, so front extruder. Should I use one material profile in Cura? Or should I use two material , say ABS and Ninjaflex, and save and modify the gcode? Or just modify start and end gcode on Cura?
I’d appreciate if you could copy here what you did or have a print screen. Thanks!