X axis moves in only one direction


I’m taking over a CAD class and the previous teacher didn’t maintain the 2 Lulzbot Taz 6 machines that he has. I have some familiarity with my Ender V2.3 at home but am still quite new at 3D printing.

I’ve been trying to set up both of them -

Printer A - When auto-homed it went past the z axis and down into the plate. Might be a calibration issue or Probe Z offset issue?

Printer B - Does not move in the positive x axis.

Since printer A was moving well, I took off the tool head to B to put it on A, however it’s still not moving in the positive X axis. It doesn’t seem like it’s a motor issue since the previous tool head worked fine. I don’t understand it.

Any thoughts on either?

First thing I’d check with B is the limit switches. If one is jammed in and constantly saying it’s at the limit, it won’t try to go any further.

For A, it should be homing the Z over the big metal pushbutton. If it’s missing the button completely, the Y axis is probably way out of position, and needs to be put back in place. Check Step #9 going forward at OHAI: Open Hardware Assembly Instructions (lulzbot.com) If it’s hitting the button with the nozzle, but nothing happens, the button could be broken, but it’s more likely that the wire from the switch is broken somewhere. Get out a multimeter and check that pressing the button causes connectivity back at the harness going into the control board.

Do you have a multi-meter to check continuity? One of my printers had a problem with the X-axis and it turned out to be a damaged wire (the wire that connects the control board to the X-axis limit switch was broken and needed to be replaced.)

You can find the instructions for connecting the wiring harnesses to the control board here: OHAI: Open Hardware Assembly Instructions

But here’s photo (from that same page):


Note the location where the X-min and X-max wire harnesses connect to the board.

You should be able to disconnected the X-max wire harness and test for continuity through that cable. I believe the limit switch is a “normally closed” switch and the connection is broken when the switch is bumped. So a broken wire would register to the control board as though the X-axis has already hit the limit switch. Connect probes to the wires and check that you have continuity while repeatedly testing the limit-switch button.

NOTE: the wire from the control board goes to yet another wire harness on the back side of the control-box (back of the printer – covered by an access plate). From there it goes to the X-axis limit switches. So check that you have a good connection on the back of the control box. That’s not normally a connection that would ever get disconnected … so it’ll probably be fine. But you should be aware of it just the same.

As for the printer that drives the head into the bed (z-axis problem)…

The printer should home all axes … then it should perform a bed leveling process. This is in the start g-code of the slicer software (Cura Lulzbot Edition).

It should:

  1. Home all axes.
  2. Heat the print-head to the “softening” temperature (for most filaments that’s around 180°C)
  3. Retract a bit of filament
  4. Cool the print-head to the “wipe” temperature (for most filaments that’s around 170°C)
  5. Lower the nozzle to the scrubber pad on the side of the bed.
  6. Run the nozzle across the scrubber a few times.
  7. Raise the head a small amount (a few centimeters) and then cool the head to the “probe” temperature (usually around 160°C)
  8. Perform a bed-level (touch the nozzle to each of the four corner bed washers.

At this point the printer should heat the head to your printing temperature and start printing once both the bed and head and hot enough.

It will use the Z-offset … which is the difference from the hight of those bed-leveling washers to the the height of the bed. The factory default is like -1.20mm.

Check your Z-offset to see if it is at or very close to -1.2.

IF YOUR BED WAS SWAPPED for a different bed … that value may not be any good. For example Lulzbot offer an optional magnetic flex-bed … and it is much higher than the height of the factory default glass bed – so the Z-offset has to be changed to compensate.

Other possibilities … the printers eprom has a value for the steps/mm for each axis. If someone adjusted those then the printer may be moving farther than it should. You could reset the eprom back to factory defaults.