Y axis jumping / ticking Taz 6


Has anyone else had a problem with their Y axis jumping on their Taz 6? It is not uniform, but jumps a few mm each time when it happens (in the +ve direction only). There is also a very audible ticking or a click from the Y axis stepper.

I’ve checked the usual things:

  • Updated the firmware on the printer to the latest version.

  • Cleaned and lubricated the slides and lead screws with food grade silicon.

  • Adjusted the Y-axis belt tension.

  • Changed the Y-axis stepper motor with a new replacement, no change (and the grub screws are tight and in the correct position)

Been waiting for close to 2 months now for Lulzbot to answer my (several) e-mails so hoping someone else can point me in the right direction.


Check that the bearing holders on the tray are tight. With the vibration and temp changes they could come loose.

Thanks, just checked and some were finger tight, so I’ve tightened them all and run a quick test print, sadly still the same.

I know this is a little bit old but that clicking noise in the stepper motor usually means power issue.
Does the clicking happen all the time or just when you are printing?

If its print time only check to make sure the cooling fan is running and connection isn’t coming loose when printing.

If it’s all the time… you might have a bad pot that can’t regulate the power to the stepper properly.

Also where did the firmware come from? Firmware controls how much current to give so I would double check the number if you compiled them your self.


I’m all sorted, thanks for the reply, happy to close the issue.


Hi there, my Taz 6 has started having this issue as well still unable to work out what the problem is. how did you fix yours Simon?

I tried everything to fix it! I was packing to move house last December, gave it one last go and it printed the test print fine so I packed it all up, moved house and set it back up yesterday. Now the the exact same problem has re-emerged.

I’ve again tightened the bearing carrier screws, replaced the stepper motor for new, lubricated the slides and made sure everything else is solid. The latest versions of Cura and the firmware (untouched as from Lulzbot) are installed.

All of the axis will move perfectly fine when you manually drive it from the jog wheel/LCD, in all 3 increments of 0.1, 1 and 10mm, across the whole range. Start a print, it moves fine to clean and calibrate, but as soon as it starts to extrude the Y-axis jumps again and no dice!

Not sure what else to try now. Have you resolved your issue?

Yup, exactly the same issue here, we think it probably the y axis stepper driver or the position encoder in the motor itself. But price of replacement board is nearly as much as a new cr-10 so wondering if it’s worth even fixing it.

I’ve replaced the stepper motor for new so can rule out the encoder, meaning the driver is probably cactus. Have you tried adjusting the current to the motor? Was going to be my next experiment, failing that :man_shrugging:. Support from Lulzbot has been painful, took over 3 months to get an e-mail reply.

Any word back from Support.