Z axis homing fail and inconsistent heights on Z towers

I have a Lulzbot Taz Workhorse which is 5 years old now. I’m having trouble with my Z axis almost every time I auto home it. Sometimes it’s no issue but then today it was showing inconsistent heights on each Z tower. One of the Z towers did something that I’ve never seen before. The belt was moving in a different direction.
I was about to print with my new Meteor toolhead but before I could, auto home failed along with the Z calibration.

Here are gifs because I can’t send video.



The gifs aren’t moving, try posting up to youtube with a direct link.

Here’s the link to the videos

For Z homing, both sides need to hit the buttons at the same time (they’re wired such that both need to be pressed for it to register). If the gantry gets out of plane enough, one side hits and “bounces” off, then the other hits the button and bounces… until it fails out.

You need to disable the motors in the motion menu, then gently, but firmly pull the gantry against the top so that both buttons are pressed. Hold it there with one hand, then use the motion menu to move the Z axis to re-enable the motors.

Auto home should work now.

If it still goes up, both buttons hit simultaneously, and it continues to try to raise, lower the Z with the machine off, then turn it back on. Try to home again, but this time, manually press those Z buttons simultaneously. If it still doesn’t stop, you’ve probably got a bad switch or wire for the Z max switches.

I will give that a try but it seems like there are other issues associated with the one you described. In the video “ Belt swaying and Inconsistency on Z axis Taz Workhorse” you can clearly see the belt swaying in a weird direction and the limit switch on that side looks wobbly. Is there a fix for the belt swaying outward towards the bed and the wobbly limit switch?

Had this same EXACT issue. It only went away when I replaced both geared steppers and replaced both pulleys. I also replaced the limit switches first, but that didn’t do it.

How do I know the stepper was the issue? I don’t know, but the issue absolutely went away permanently when I did.

The left and right sides of the gantry should never get out of sync, if it does there’s something majorly wrong with the motion. I have a Taz Pro XT for example, and I could run gcode to move the gantry up and down to the top and bottom 50000 times and it will still be exactly level.

None of these parts are easy or cheap to find.

Makes sense! I wonder if it might be time to replace some parts since I’ve had this printer almost 6 years now and for 2 of its years I was learning how to use it. For 2 years I kept it in a garage which doesn’t have air conditioning. Temps would reach 90+ in the summer and below 32 in the winter which probably explains some of its problems. It’s not under the stress it was 3 years ago. It’s probably showing its exhaustion from holding up to all the mistakes I’ve made with it (example: putting it in the garage).

You mentioned that both the pulleys and the stepper motors were the issue. Did your belts sway like mine did in the video? I’m wondering if I should replace the pulleys also?

The belts thing you are seeing is probably on the side that hits the top first, while it’s waiting for the other side to hit the limit switch. Both limit switches have to be hit to trigger the end stop. So it continues to grind away trying to move the side up that cannot move any more.

If it was in a garage, the stepper gear boxes might be bad. I took mine apart before I replaced it, and it does have a fair amount of grease in it so maybe?

Have you tried to relevel the gantry with the power off? If so, if you were to move the gantry via the LCD to the very bottom and then rehome - is the gantry off kilter after one travel move?

I solved the problem! The limit switch was loose!
Link to video


Good to see it working. Sometimes it’s those simple mechanical failures that we look for last.

I had an issue with probing with my modified dual extruder on the pro, which uses a simple microswitch. Turns out a little piece of plastic was on the front of the toolhead, causing the toolhead to angle, delaying the pressing of the switch. That resulted in the bed probing being off by about .2mm from the change in angle.