Auto Home Problem

I am able to drive the z axis up and down with the LCD controller without issue. No binding, grinding, or funny noises of any kind. When I hit auto home the z axis will freeze at whatever its current location happens to be and I hear a humming noise. ( Sounds like its coming from the stepper motor but can’t be sure ) I’ve been having this problem sporadically since receiving my printer about a month ago ( Usually when starting a print because it homes before each print ) but I’ve always been able to cure it by simply turning the printer off and back on again. No such luck today. Cycled power on the printer and power supply, both to no avail. Anybody had this issue before? Any ideas?

Thats not normal behavior. You probably want to call support. It could be a loose Z home limit switch, a loose or shorted wire to one of the motors, or something else.
video of the issue in question

It definitly sounds like the motor is in opposition to itself, where the two magnets are fighting each other instead of turning. But you said it moves normally with the Z axis commands elsewhere, so that probably isn’t it. I’d be curious if the other motor is doing the same thing.

Another possibility is that you are out of level and the leadscrew is jammed in the leadscrew nut. Check the distance from the bottom of the leadscrew nut to the top of the leadscrew lower bearing on both sides and make sure it is the same.

Since everything works normal off the LCD, sounds like it could be a computer USB to controller connection. Are you using Windows 10 by some chance? I wonder if it will print off the SD card, pretty advanced for a new user. Call Support in the morning, they may want you to reload the software first.

I am using Windows 7. I have tried tethered and untethered. Also it makes no difference if I’m trying to print or not. Every time the machine auto homes, this problem occurs. Last time it happened I grabbed the lead screw and turned by hand and turned it about a quarter turn. The motor took over for the remainder of the turn then froze again.

Any solution for this problem?
I have just unpacked my total new TAZ5 and have exactly the same problem :frowning:
I could move the Z axis up and down with the manual control but pressing home I get this sound from the stepper motors.

Really need to solve this problem urgently, have to start print details latest tomorrow for a delivery to a customer.


I am assuming your using the TAZ branded Cura, you might try reloading the software. The Home sequence should be in the gcode not the machine. I no longer have my TAZ so I can’t really be of that much help. One other remote possibility, the Z motors can be out of sync, but since it works off the LCD fine I don’t think so. Both motors are driven off the same Z axis controller so one could be a 1/2 turn or so off from the other. It happened to me, but the bed was not level and that was the only clue.

I put an email into support this morning. No response yet. I will let you know what they say as soon as I hear back. If you would do likewise that would be awesome. I too need to get my taz back up and running to fulfill some orders.

It’s a federal holiday in the U.S., so the may have today off as well.

Good call. Didn’t think of that.

Following up on this. I finally got a chance to call in to support this morning. They did an awesome job! Had me up and going again in a matter of minutes. The issue turned out to be with the control box. The chip driving the z axis can start to have heat issues because of the draw from the two stepper motors it drives. In short, it gets hot and then your z axis stepper motors get out of sync.

Here is what they had me do:

  1. Using the ruler in the tool kit, measure vertically from the aluminum plate of the heat bed to the smooth guide rod of the x axis. Mine was off by a couple of centimeters.
  2. Disable stepper motors and drive the high side down to level by turning the lead screw with your hand.
  3. Go to Configuration/Advanced Settinngs/VMax Z. Mine was set to 8 I changed it to 3. This slows down the movement of your Z Axis.
  4. Exit menu and save settings.
  5. Auto Home

At this point everything resumed normal functionality. I was told there are a few more things to try if the issue arises again and to not hesitate to call back.

Had to go to work so I haven’t been able to re-level and run any test prints, but I did run the z axis up and auto home numerous times without issue. Hopefully this is helpful for someone else in the future that encounters this problem.