Z axis missing steps

Hello all,

This is my first post, but I have been running into some issues with my KITTAZ. It seems like my right Z axis stepper motor is constantly missing steps. Let me explain.

After a successful print, the right side of my gantry will always be a few millimeters higher than the left side. I take a carpenters square and measure from the top of the frame to the top mose X axis rod, and have to manually rotate the lead screw to bring the right side down, powering the printer off before making this adjustment. I have adjusted the travel speeds in the Z direction to never exceed 200mm/min, but it is always the right side of my printer that seems to have issues.

Am I missing something, or has anyone else run into similar issues? Any thoughts or comments are appriciated.


Round Rock, TX

First check if you can easily rotate the screws manually with the motors off. If you can’t, you might want to check the alignment of the x-end, screw, rod setup. If you can rotate them easily, it might be a wiring issue. Check for a loose crimp or otherwise bad connection to the stepper motor on the low side.

Any chance you’re using an enclosure that also traps the air in/out of the electronics box? I had horrible HORRIBLE problems on two occasions when I let the enclosure inside-top temp get up to about 45C. At that point the at-the-table temp was about 38C, which means the air supposedly “cooling” the stepper motor drivers and electronics was already hotter than was appropriate. On those two prints, my Z-axis simply stopped moving. At all. I had one 100mm-tall print where the Z-axis simply stopped moving at around 65mm, but the dumb thing still thought it was doing fine. The LCD even reported Z at 100.2mm, but it was nowhere near there. Instead the head was embedded waist-deep in a veritable carpet of plastic chaos on the part top, and the hobbed bolt had done its thing on the filament, etc., etc.

The lesson (it seems to be working now) is don’t let the ambient air around the electronics/stepper motors DRIVERS get into the 40+C range, or those switches might just stop working until they’re cool enough. I wouldn’t be surprised if the servo driver chip’s thermal shutoff was cutting in. The reason I don’t think it’s the motor itself is that the z-axis stayed perfectly level the whole time and is still just fine, so both motors clearly were not responding to…what likely was no signals from the drivers.

I have since then thermally isolated the electronics from the print enclosure by ducting both the intake and output through the side wall. Now it takes in cool air (20C) and puts out normal warm air (~30C), even when the enclosure itself is in the 40C’s. Granted, after seeing that mess I’m a little skittish about letting it get much about 40C in there (at the top of the box; bottom of the box stays around 30C). Next step is to see if there’s a way to heatsink the drivers wholly inside the electronics enclosure, so the drivers aren’t trying to push heat into an already-hot metal case, and they can have a nice air-cooled heatsink like they like.

So, if you’re recirculating warm/hot air into the electronics enclosure, watch that the internals aren’t getting unhappy in the heat. If you have an insulated temperature probe, maybe insert it into the box while it’s running and monitor the temp.

Hope that helps.



While poking around in the current (2014Q3 I think) version of Marlin that I’m using, I noticed a setting in the configuration_adv.h file with this useful-seeming name and description, at line 155 or thereabouts.

// #define Z_LATE_ENABLE // Enable Z the last moment. Needed if your Z driver overheats.

I have enabled that by removing the first //, and will see if I have more problems. I suppose I should do a print with old while measuring temp, then new of same print, but it’s already changed and uploaded and printing something else…:smiley:.

Anyone know whether that’s just some useless old hack, or is somehow counter-indicated on the TAZ4? If I can get my build enclosure into the low 40’s without having the Z-axis blindly fail, that would be a happy-happy joy-joy kinda thing.

Regards and Thanks,


Aaaaand it looks like it’s a winner. Did a large print and let the enclosure self-regulate. Not only was it overall slightly cooler, but the ramp-rate of the heat was lower too. I didn’t notice any issues with the Z-axis stepper motors taking somehow longer to respond, or moving outside computer control. They motors, and the drivers too were noticeably cooler. The electronics case stayed cooler, heatsink. All 'round it seemed a good fix. The 10-hour temperature was 45C at the top and 30C at the bottom. With no issues. Before I’d get Z-failure issues as cool as 39C once. So, tentative, possible fix needing further testing.

Now someone can go look at the code and tell me “yeah…that stuff was commented-out in 2001…” :wink:


Thanks for all the responses,
My Z axis lead screws rotate fine when the printer is off, so no mechanical binding.
And I can replicate the problem just after turning on my printer before anything really heats up, so I’m not sure if it is a driver overheating issue. The printer is sitting on top of a small shelf, and the fan on the side of the enclosure seems to be spinning away, unobstructed.

My real issue seems to be that if the entire X axis carriage travels a lot in the Z direction, then the right side of my carriage is always lower than the left. I just swapped the two Z axis steppers, but the problem stayed on the right side.

If I run the carriage to is maximum and home positions a few times with the LCD controller, after about 4 runs, the right side is seems to be about 1/16" lower the the left. I am measuring with an adjustable carpenters square against the top frame rail, which as best I can tell is level with the bed.

Unless something is strange with that stepper driver or in the harness. :confused:

Make sure that you are using a white lithium grease (lucas #2) on your lead screws. You should be greasing your Z axis drive rods every month.

Can you use a dry lube? I’ve been using it on my cnc with good results.


Lucas is what we use internally with the fleet, so it’s what we recommend so far.

Huh. My rods have been dry since day one. I’ll lubricate them and see if the problem continues.

Thanks Orias!

I added the lucas grease to the rods, and the operation seems a lot smoother, but it is still not staying consistantly level.

If I have the head move from home to +250mm and back, a few times, then the two sides of the X carriage are not level, the right side is always higher, (3 trips 0->250->0 and it is higher by about 1.5mm).


I’m going to email support on Monday and hopfully they can help me out. :confused:

Hi I am now on my second TAZ 4 printer that is having z-axis binding. As with some of the other posts I have confirmed that the binding is not mechanical. I can manually run the Z-axis up and down and also using software to run it up and down but as soon as I try and home the print head the z-axis binds. I believe there must be some kind of design fault ans many users are having the same problem. When I spoke to hardware support I get the impression that I am the only person having this problem. Hoover after reviewing this forum it seems if many people have the same problem.

What I dont understand is that the TAZ 4 gets so many positive reviews on Amazon ? Are these reviews fake?

Come on LULZBOT lets sort this problem out!!! It is currently making this printer unusable!

My left z started binding today also. I have been printing since i got it in November with no issues. Today while homing to start a new print the left z stepper made a bad noise.

I can move it up and down by hand fine and through through the menu fine until it gets near the z stop, the. It binds up.

Missing steps:
I also found that Z started missing steps on my Kittaz/Taz4. Similar set up, heated PID controlled enclosure with rambo in the heated envelope. I was expecting to see something happen after talking with customer service beforehand. They said Z axis would be the first point of failure. I set my controller to 40C and once it reached it and crept over (up to 45C, enclosure insulation worked better than expected) I lost steps. I periodically checked z steppers with an infrared thermometer and they hovered around 60C which is ok. So I concluded the A4982 stepper driver was hitting it’s shutdown temperature. I haven’t directly measured it yet though. If you look at the rambo schematic the driver for Z is driving both motors.

I have a few options.
-Extension harnesses for the rambo to isolate it from the heat envelope.
-Print ducting to introduce cooler air.
-Thermal epoxy heatsink to the A4982(doing this regardless).

Z binding:
I had this same problem and discovered the framing itself to be the problem. My issue was the squareness of the overall assembly. I would adjust the x end motor and idler sub-assemblies, test, and at a certain height would bind again. It wasn’t fixed until I adjusted at Z min and max travel by loosening the frame brackets. So in my experience the frame was either tapered in or out.

I personally use Super Lube synthetic PTFE grease on my lead screws. I chose this because I knew from the onset I wanted to have a actively heated enclosure and I wanted something that wouldn’t seperate with time or at temperature. Here is the MSC part number 00257006