Z homing issues

Hi guys.

I have a taz5 and have upgraded my firmware to Now I am not allowed to home my Z unless the X and Y are homed as well. I use manual bed leveling what do I need to change to get the z to home where ever the x and y are?

Thanks in advance

Gary :smiling_imp: :smiling_imp: :smiling_imp:

I have the exact same problem. Anyone have a fix?

When leveling a Taz 5 bed I’ve always homed all, then I’ll disable steppers and move the tool-head and bed corner to corner by hand. Then I’ll home again, disable steppers, check my work, rinse and repeat as necessary.

I think this has something to do with Z safe homing that’s been enabled on the Taz 5 recently. If you notice the tool-head moves to the right a bit after homing the X axis. I’m pretty sure this allows you to use a Taz 6 V2.1 tool-head on the Taz 5 without modifications. Since the Taz 6 tool-head has an extra fan on the left side it would normally collide with the Z thumbscrew otherwise.