Z-Offset Ignored

I got the new Flex Bed and I have installed it. My original Z-Offset was -1.26 mm. The instructions to install the new Flex Bed say to add at least 1.5 mm to your current offset and tune from there. I adjusted the Z-Offset to 0.24 mm and tried a test print. The nozzle gouged the hell out of my new flex board. I added another 0.5 mm to the Z-Offset and it did the same thing. I added another 3 mm to the Z-Offset to see if it was even being used. It wasn’t, the nozzle gouged right into the new Flex Panel. I make changes to the Z-Offset, save them, re-home the printer, and then try my print. My start GCODE is below. Almost all of it comes from the Lulzbot version of Cura that ships with the printer, but I use Simplify3D. Any help on this would be greatly appreciated.

;This G-Code has been generated specifically for the LulzBot TAZ Workhorse with HE 0.5mm Tool Head
M73 P0 ; clear GLCD progress bar
M75 ; start GLCD timer
G26 ; clear potential 'probe fail' condition
M107 ; disable fans
M420 S0 ; disable previous leveling matrix
G90 ; absolute positioning
M82 ; set extruder to absolute mode
G92 E0 ; set extruder position to 0
M140 S{material_bed_temperature_layer_0} ; start bed heating up
M109 R{material_soften_temperature} ; soften filament before homing Z
G28 X0 Y0 Z0 ; Home all axis
G28 Z;
G1 E-30 F100 ; retract filament
M109 R{material_wipe_temperature} ; wait for extruder to reach wiping temp
G1 X-15 Y100 F3000 ; move above wiper pad
G1 Z1 ; push nozzle into wiper
G1 X-17 Y95 F1000 ; slow wipe
G1 X-17 Y90 F1000 ; slow wipe
G1 X-17 Y85 F1000 ; slow wipe
G1 X-15 Y90 F1000 ; slow wipe
G1 X-17 Y80 F1000 ; slow wipe
G1 X-15 Y95 F1000 ; slow wipe
G1 X-17 Y75 F2000 ; fast wipe
G1 X-15 Y65 F2000 ; fast wipe
G1 X-17 Y70 F2000 ; fast wipe
G1 X-15 Y60 F2000 ; fast wipe
G1 X-17 Y55 F2000 ; fast wipe
G1 X-15 Y50 F2000 ; fast wipe
G1 X-17 Y40 F2000 ; fast wipe
G1 X-15 Y45 F2000 ; fast wipe
G1 X-17 Y35 F2000 ; fast wipe
G1 X-15 Y40 F2000 ; fast wipe
G1 X-17 Y70 F2000 ; fast wipe
G1 X-15 Y30 Z2 F2000 ; fast wipe
G1 X-17 Y35 F2000 ; fast wipe
G1 X-15 Y25 F2000 ; fast wipe
G1 X-17 Y30 F2000 ; fast wipe
G1 X-15 Y25 Z1.5 F1000 ; slow wipe
G1 X-17 Y23 F1000 ; slow wipe
G1 Z10 ; raise extruder
M109 R{material_probe_temperature} ; wait for extruder to reach probe temp
G1 X-9 Y-9 ; move above first probe point
M204 S100 ; set probing acceleration
G29       ; start auto-leveling sequence
M420 S1   ; activate bed level matrix
M500 ;
M425 Z    ; use measured Z backlash for compensation
M425 Z F0 ; turn off measured Z backlash compensation. (if activated in the quality settings this command will automatically be ignored)
M204 S500 ; restore standard acceleration
G1 X0 Y0 Z15 F5000 ; move up off last probe point
G4 S1 ; pause
M400 ; wait for moves to finish
M117 Heating... ; progress indicator message on LCD
M109 R{material_print_temperature_layer_0} ; wait for extruder to reach printing temp
M190 R{material_bed_temperature_layer_0} ; wait for bed to reach printing temp
G1 Z2 E0 F75 ; prime tiny bit of filament into the nozzle
M117 TAZ Workhorse Printing... ; progress indicator message on LCD

Just for my sake positive numbers mean down and negative numbers mean up.

To hopefully illustrate what I interpret what you said in your OP. Your original offset is .26mm above the glass plate and 1.26mm above the metal base plate. These numbers roughly come from the combined size of the glass plate plus heater(roughly at 1mm) and then to offset where it probes( the metal corners which are ~.2 mm above the glass bed surface). For those reading when we say add we mean moving away from the ground. Continuing you set the offset to 0.24mm, this lead to the nozzle trying its hardest to go through your now metal plate because it now thinks it is trying to print 1.5mm lower than it did before. I think those reading get the point that we dont want positive numbers. Try setting your z-offset to -1.6 and then using small increments bring the z-offset closer to your new Octograb bed.

I set it to -1.6 mm and it made no difference. It still tried to push through the bed. I set it as low as it would go, -2.0 mm (the knob was unresponsive at that point) and it tried to push through the bed. It is like the unit does not care what I set for the z-offset.

Support should be able to help you diagnose any firmware issues, you can also try using gcode commands rather than the lcd to double check that settings are saving to eeprom.

I put a Flex Plate on my Taz. My video has some settings and may help. The numbers may be a little different and I been use Octoprint.

Thank you for the video. I ended up taking a much harder look at my GCODE and found the issue.

G29       ; start auto-leveling sequence
M420 S1   ; activate bed level matrix
M500 ;
M425 Z    ; use measured Z backlash for compensation
M425 Z F0 ; turn off measured Z backlash compensation. (if activated in the quality settings this command will automatically be ignored)
M204 S500 ; restore standard acceleration
G1 X0 Y0 Z15 F5000 ; move up off last probe point
G4 S1 ; pause
M400 ; wait for moves to finish
M117 Heating... ; progress indicator message on LCD

The mistake is the 2nd and 3rd line there. I was turning back on bed leveling and saving the results BEFORE the bed leveling was done. I moved the 2nd and 3rd lines to just after M400 and it works fine now.