Z-offset in Cura, where is it???

I am trying to find where I put in a Z-offset in Cura. I have looked in the basic, advanced, machine sections of cura. Do I have to add it to my gcode.
I am using the Lulzbot Cura software.

Also once I find out where to put the offset number. What is the procedure for determining what that number should be.

Thanks for your help on this.

I was able to find where to enter the z-offset. I was using a older version of cura that did not allow for a z-offset entry. I believe the version was 14.9. I upgraded to 18.3 and the z-offset shows up in the machine area.

But I still have one question about Cura, Is there a way to extrude 100mm of filament at a time. I want to check my e-steps and I can’t find a way to extrude that much filament when I bring up the print section. It only goes as high as 10mm

Type these codes into the line below the big status box in Cura:
(Hit return after each one)

G1 E10 F50

The middle line should extrude 10mm of material at 50mm/sec.

Change the 10 to a number of your choice, and extrude away. Try the 10 first just to be sure it works.

The G91 sets it to relative positioning.
The G90 sets it back to absolute positioning.

Let me know if this works for you.

Thanks for that info. I had been switching from Cura to Pronterface when I needed to extrude 100mm for the extruder e steps calibration, since Pronterface lets you set the amount to be extruded. It was easier than hitting the 10mm extrude button 10 times in Cura (especially when I lost count: “was that seven hits completed, or am I just about to hit it the 7th time?”)

BTW… I find it helps to do a 10mm extrusion just before you mark the length of filament for the e steps calibration procedure. That way, you take any “slop” out of the system if it’s been sitting a while, or if it retracted the last time it was used. So I extrude 10mm, mark the filament at 100mm (or 120mm, depending on the procedure you are using) then extrude the 100mmm and measure.

I could be wrong, but I don’t think you need to prime the hotend to ensure the machine is feeding the requested amount of filament. Priming would make sense if you are measuring the extruded length, but we’re checking that the stepper motor is feeding 100mm to the hotend and more or less disregarding the extruded filament. Not a necessity, but I guess it wouldn’t hurt to prime… :slight_smile:

Good point. I guess I’ve been wasting filament. I think my habit started when first tried to set the e steps on a newly installed print head. I hit “go” to extrude 100mm of filament, and watched the main drive gear spin, but nothing was happening for about the first 20mm, even on the inlet end (turns out I had the idler arm tension set too low, and had partially chewed up the filament). Ever since then, I’ve “primed” the extruder before setting e steps. Most of the time, I probably didn’t need to.

So from what I am hearing from this post there is no easy way of extruding 100mm of filament in Cura, like there is in MatterControl
You need to enter the following commands.
G1 E10 F50, when doing this command for extruder e steps calibration, does it matter what the F50 is set to.

I’m no expert on this, but I believe I read something about not extruding too quickly to get better accuracy?? (Not sure what would cause this - maybe a build up of back pressure in the extruder could cause slipping?) The extruder calibration ohai mentions extruding 100mm at 100mm/min, so that’s what I did. That was the only reason I downloaded Proterface: it was linked in the e steps calibration procedure, and it has a convenient was to set extrusion length and speed. Ive just been using Cura for my actual printing so far.

The software you use to print the gcode saved from Cura would be better for manually extruding filament.

Repetier is what I used to control the printer in my Slic3r days… Octoprint allows you to extrude filament manually also. But to answer your question, it doesn’t seem like the Lulzbot version of Cura allows for direct printing.

Kitchen, thanks for the response.
Question, what do think about simplfy3d, would it allow me to extract 100mm of filament and do they have profiles for the different filaments and the TAZ 5 available to download

Ok, I’m a total Noob here. “The software I use to print the gcode saved from Cura”? I’m not sure what you are talking about. I load an STL file into Cura, click on the control button, and hit “print” (a little more complicated, since there are a few things to do within the control dialog before clicking “print”). I don’t have other software involved, other than some simple CAD stuff to create the STL file in the first place.

So I’ll preface this by saying that I use Octoprint to control the printer. My workflow involves slicing the STL in Simplify3D. Save the G-code, and upload to Octoprint to print.

I thought Cura had printer controls… but couldn’t find it on the version I installed (Lulzbot Cura 17.10).

Just opened up the print panel in S3D and it doesn’t seem to perform a manual extrusion either.

Octoprint’s control panel allows for manual extrusion of filament… I’m pretty sure of that. :slight_smile:

So you just put in the amount of filament to extrude, and press “Extrude”.

To find the printer controls in Cura, you have to first load an STL file. Then click the “control” button. This will pull up the printer control window. This window has manual extrusion controls, including a button to extrude 10mm. There is no adjustment on the 10mm; it’s a fixed number. AFAIK, the only ways to get Cura to manually extrude 100mm is to press the 10mm extrude button 10 times, or type in the gcode noted earlier.

NOTE: if your printer is not hooked up, there is no “Control” button. It shows up as a “save gcode” button instead.

That’s probably my issue… printer isn’t hooked to the USB port.

NOTE: the workflow for calibrating e steps just says to set extruder speed to 100. It gives NO units. Since they are referring to using Pronterface, and it’s units are mm/min, you can infer that they mean 100mm/min. This is quite slow.

If you are actually using Pronterface, it will be pretty straightforward (even for a Noob like me). If you are doing this in Cura, the units are in mm/s, so the equivalent would be between 1 and 2mm/s. (I don’t know if the gcode listed above will accept decimal points, but the actual equivalent would be about 1.7mm/s).

If the Lulzbot tech support folks are monitoring this, I’d suggest adding the units (mm/min) to the workflow description (step #4 here), and perhaps pointing out that folks should check whether they are setting mm/s or mm/min if they are using some other software. My initial attempts to calibrate e steps by hitting the 10mm manual extrude button in Cura 10 times were not getting me consistent results. I wonder if speed was an issue?

You make some mistakes there. Curas settings are in mm/s, but gcode is always defined in the same way. The G1 command takes the speed with the “F” parameter in mm/min, so it’s just right to enter G1 E100 F100 for example. Yes, the parameters support decimal points, you may have a look at the list here.

By the way, 100mm/min for extrusion speed isn’t slow, it’s realy fast! As I calculated in the the other thread, values around 40-50mm/min are a common speed. With 100mm/min you get nearly 12mm³/s of filament, that’s not even feasable with some printers. I testet the TAZ5 up to 10mm³/s and it’s OK with this printer, but don’t think you can do this with every one…

My mistake. I see where I got mixed up, I was confusing print speed (basically the speed at which the head moves as it lays filament down on the bed with filament feed speed. Two completely different things (though they are related). You listed print speed as typically 40mm/s for infill in the “Can’t Get Prints to Correct Size” thread)

Now that I’m not mixing those two up (and their units), I’ll try calibrating the e steps at something slower than 100 mm/min. In the other thread, you mention that I will see differences in the 100mm measurement if I run the test at 20mm, 50mm, and 100mm, I can understand that (though I’m not sure why it happens: Is the motor “stalling” or missing steps at the higher speed, possibly due to back-pressure in the hot end?). If I’m looking for accurate sizes when I print, is testing the e steps calibration at around 40 or 50 mm/min the best speed to do it, since that is close to what you mentioned equates to a “normal” print speed?

To be shure, you should use extrusion speeds that are roundabout something you are using later in your prints.
The reasons can be skipped steps and “slipping” on the hobbed bolt. Usualy it’s not realy slipping, but the filament can start to creep. To give a comparison, my values are between 801 for lower speeds (measured between 20-40mm/min) and about 840mm/min at ~100mm/min which was set from factory. That’s the difference between overextrusion and nice prints…

Thanks, Sebastian. As suggested, I’ll confine further discussions to the other thread - the subject line more closely relates to this discussion anyway.

Sebastian, where do 801 & 840 numbers come from. Not sure where you got these numbers.
So should I enter g1 e100 f50 or f100