Can't Connect to Printer - Communication Error Lulzbot Mini 1

Hi there,

I’ve had my Lulzbot mini since 2014 and have had lots of good use out of it. The power supply was upgrade a few years ago and I’ve been keeping up to date with firmware and the Cura for Lulzbot (current version 3.6.21).

Today, after years of printing I am unable to connect to my printer via USB and I suspect it is serial communication issue with the RAMBo board within the unit. Cura can see the printer, as well as my Device Manager reports it as working properly. I’ve updated the drivers on my windows 10 PC and made sure the OS is up to date (and of course restarted). Also tried a different cord.

When I open Cura it says ‘USB device available’ and when I click connect, sometimes says ‘connecting’ for a few seconds, but mostly says ‘can’t connect’. Baud rate at 250000 (tried em all anyway) and com port selected to auto. I tried to upgrade firmware but I get a window saying ‘communication error’.

I’ve opened up the unit and inspected the fuses which were all fine. I suspect there may be a failed onboard component within the serial communication circuit at some point but I am not an electrical engineer unfortunately so I think my experience has run out.

If you guys have an suggestions on what else I can attempt to fix myself or to just suggest a board repair or replacement, I would appreciate the support!

I’ve emailed lulzbot support twice over two weeks without any response so I’m hoping somebody can help me here.




LulzBot had a huge downsizing which affected their tech support. So, good luck with that avenue. There are a couple of things that you can try.

Since your printer is so old, I would check the USB connection on the board. If it’s loose, you’ll have to replace the board. The board you’ll need is this one:

You can try calling there sales department because everything shows out of stock on their web page. The number is 970-203-0831.

Currently, they are on shaky ground while they find a new buyer. You can also get it from Ultimachine.

You’ll want to specify that the board is for a Mini 1.

Before you buy the board, make sure that your permissions didn’t change on your computer and that your logged in as an administrator. That’s the first thing I would check.

Thanks for the response. Yeah, a friend had mentioned that lulzbot was going through some change. When you mention the USB port being wiggly, what am I looking for specifically? A broken solder joint on the connector on the board? I had noticed this looseness a cou0ple years ago and added some more solder for stability. It would seem its still pretty sturdy. I’m sure I can find a generic RAMBo from somewhere else for cheaper., $100 seems steep.

Seems like permissions are fine and what not.

Ordered a board from amazon for $90 to save some money.

I left a review if anyone wants to buy this board, i would probably try to find it from somewhere else.

Nonetheless, the new board works and i’m printing again! Hope this doesn’t happen to someone else.

Hello - Did you ever find a solution? and what was that? This is my exact situation, too.

UPDATE: Just after leaving that question, I went to delete Cura LE 3.6 and noticed I also had Cura 14.09. I deleted Cura LE 3.6 and fired up Cura 14.09 and it worked! Good enough for now. I’ll work out how or whether to move to later versions later.

1 Like

If you can use your 14.09 version of cura to manually update to the latest firmware it should be able to integrate with the more recent versions of cura

1 Like

Hey, wow this was a while ago haha.

Yes, this worked like a charm. I cheaped out a bit and got a knock-off and had to touch up some of the PCB solders before I felt good enough leaving it inside the printer. Once flashing the newest firmware it worked perfect again.

I was making some modifications to the print head and cross the red wires at the tip. Turning it on, it could no longer detect the bed while doing its bed leveling routine. Alas, another replacement board will more than likely fix this as none of the fuses are blown and google agrees I could have blown a chip or many chips (although everything else seems to work fine).

I’ve moved on to a Prusa MK3S since then and have had great success. The mini sits in a dark corner, somewhere unknown.

1 Like