Cant start Cura 3.2.32

Hi Forum!
Got a new computer, and went to install the new version of cura (v3.2.32)… big problem. I can’t get the software to load! The splash screen appears and then I get a ‘user agreement’ modal, but there’s nothing visible on the form (all white) then it becomes unresponsive and crashes.

My graphics drivers are fully up to date.
Appropriate firewall rules in place.
I’ve tried clearing the cache… nothing seems to work.

I’ve attached my error log, and sincerely appreciate the help.

cura-lulzbot.log (206 KB)


Emailed lulzbot, they thought it was a corrupted download/firewall issue.
It was not a download/firewall issue.
My laptop has two graphics cards (intel and NVIDIA).
It worked when I disabled the integrated intel GPU and ran only off the nividia (device manager> display adapters> right-click > disable).
You can try running the application and choosing the graphics adapter (dig around in your nvidia settings, and use google). This enabled me to launch the program and it would run, but only as a blank white window. Nothing usable.
Unfortunately, every time I want to slice, I need to temporarily disable my intel GPU.
Hopefully there’s a more permanent fix in the future.

I disabled my graphics card also and tried to run on nividia card … went to re enable my intel card and invidia was no longer on the list … i had uploaded some update stuff from there tech dept… decided to uninstall the recent downloads slipped and acidently uninstalled my nividia … it was installed at the factory and i don’t have a cd to reinstall … there went my so called good graphics card…