Control Button Missing

In the Cura software, I see no Control Button. I re-downloaded the software twice and reinstalled, still nothing. Tried on OS X 10.11.2 as well as on a Windows 7 machine, same problem. I had the Rocktopus model loaded and the Lulzbot mini connected and turned on. So I’m dead in the water without that button. The Cura software is version 18.03

Please any ideas?

What, exactly, are you trying to do? While Cura has a number of buttons that control features, I do not recall a “Control Button”.

The control button is how you set the temperature and basically control all printing. You have to have that button or it won’t work.

If you want to make changes to the temperatures, etc. You need to exit “quickprint” and go into full settings mode. (Expert tab). Once you are in full settings mode, you should be able to see the controls you want. Hint, for a starting point, use the profiles provided by Lulzbot. ( or

Thanks I will give that a shot.

Do you have the right machine selected?

If you are only seeing the Save Gcode button, that says it is not recognizing the RAMBo card. You may need to installed the driver for it again.

I got the official word. The newest version of Apples OS (el Capitan) changed the USB ports and virtual serial port settings. The official response is, “We are trying to find a fix, but currently it does not look good. It works fine in every OSX leading up to El Capitan.

So if you are using the current version of OS X 10.11.2 and you expect to use the Lulzbot, you are out of luck since it no longer works. If they are able to find a fix for this, and I get it to work on a current OS, I will post what I find out.

As of this point, I’ll have to go buy a junker PC somewhere.

Not to throw a wrench in the mix, but I recently clean installed El Cap on a Macbook Pro and I can use my Mini just fine. I usually use Octoprint, but I started out using a direct connection. I have used Cura and Simplify3D.

Do you see it in System Profiler when plugged in?

Oh that’s not a wrench! That’s helpful. I didn’t know about Octoprint. However, the system profiler did not show the Lulzbot Mini as a connected device. I tried it in every one of my USB ports just to be sure and never saw it. I’m on an iMac though, not a laptop.

I see Octoprint needss to be installed on another connected device, such as a Raspberry Pi with a direct connection to the printer, so the device becomes wireless. Not really a solution for me.

How strange. On my system it shows as a Rambo board, didn’t have to do anything to make it work. I’m surprised it would be a problem, as USB-Serial is a standard device on OSX and Linux, and generally they just work. However, searching around it sounds like there are a lot of devices having issues with it. It sounds like some people have been able to get things working by rebooting into recovery mode and disabling System Integrity Protection, at least temporarily. It might be worth a try in your case to get things working. From what I’ve read, you can turn it back on after things are working. I found some instructions…

boot mac into recovery mode (command+r). hold it down until you see the mouse cursor
utilities, terminal
csrutil status
probably says enabled
csrutil disable

After the reboot, try connecting the printer, maybe reinstall Cura. You can re-enable the protection stuff the same way, just change “csrutil disable” to “csrutil enable”.

Yes, I should have been more clear that the Ocroprint setup is on a Raspberry Pi. I like being able to send a print to it and not have to worry that the computer will reboot or similar. I also like remote monitoring with the camera.

Disabling System Integrity Protection is not a bad idea. I’ll try that.

I might consider the Raspberry Pi thing also. Which model did you buy? It sounds like you installed a camera on it as well? I guess I’d be looking at PI 2 Model B, a Camera Module and a USB WiFi module? And then once set up, do you still use Cura to send the model data?

I used a Pi 2, along with the pi camera module. I didn’t use a wifi module, as I have wired ethernet available. Don’t forget a power adapter if you don’t have an old cell phone charger or similar around. Most places that sell the Pi have inexpensive power supplies for it. You will also need a microSD card, I used an old 2GB card I had sitting around.

I printed that case setup and have been happy with it. The stock camera cable is a bit short for that location, but not bad. Adafruit sells longer cables if you end up wanting one. I got an 18" as I was originally planning to mount it to the bed, but I decided I liked the location at the top better.

It has a built in version of Cura you can use if you want to, but I just use Cura and Simplify3D to save GCode files. Then you can drag and drop them onto the web interface for Octoprint, and click print. The built in one looks harder to configure as it works with the ini files from Cura. So if you want to slice with different settings, you have to upload that ini file, then use it to slice the STL and print.

That’s very helpful. I might just give that a try. Simplify 3D looks pretty good too.

I’m running Cura Lulzbot Edition 17.10 on a MacBook Pro running OS El Capitan (10.11.2) with no problems. I missed that version 18 was out. I’m hesitant to update it if there are problems. How widespread is the issue?

If I could somehow get Cura Lulzbot Edition 17.10, I could give you the exact answer. :wink:
I just know Cura 18 does not work on my iMac with el Capitan 10.11.2.
Of course, 10.11.3 came out today…

The Lulzbot version of Cura is available for download

You can get older versions of Cura LE here
Let us know what you find @FlashInPan

I downloaded version 18.03 of Cure LE (and kept my copy of 17.10 just in case). It looks the same on my computer when I launch it. I’ve removed the toolhead from my printer, so don’t want to power it up right now (wasn’t sure if powering up with a missing toolhead would cause problems). I did notice that in both the old and the new version, there is no control button. Where it used to be (IIRC), there is now a “Save GCode” button.

I’m wondering if this is just because there is no printer connected to my computer now, so no reason to display the printer control box? If that’s the case, I wonder if @FlashInPan is not connected to the printer, or has a bad USB cable or something similar that is preventing Cura from recognizing the printer.
[Edit: Sorry - I missed the part that you had already discussed that Cura was not recognizing the printer]

Good points, but I know for a fact the cable is good because I tested it with a PC and it connected fine. On my Mac I tried it on all my USB ports to be sure that it wasn’t a bad port. When I checked the System report on the Mac, it did not indicate that there even was a USB device hooked up (that was the Lulzbot). All other USB devices work fine.

When the control button is missing, it indicates that it does not see the printer. That’s the whole reason I can’t print from my Mac. Which makes me really bummed since the PC (I have) takes forever to load the control button and estimate print time.