Incommunicado Mac and printer host choices

Hey all,

I got my new Taz 5 7/22/16, but have yet to print anything. In the process of trying to iron out some wrinkles, among them being that the Cura host software on the Taz 5 does not work (i.e., the computer will not connect with the printer, something about Apple security and baud rate) with the latest Mac OS (El Capitan) . Apparently, even Aleph Objects has had to downgrade their Apple OS to Yosemite (the OS before El Capitan came out…Apple is apparently going through a national parks phase after using up every cat name). It’s kind of an ordeal to erase and re-format the hard disc in order to downgrade, including the cost of a back up system if you do not already happen to have one.

So, I’m wondering if changing the printer host might not be an option? I did down download Mac Pronterface from Lulzbot and had the same connectivity issue. My software understanding is limited, and since I’ll be learning something new anyway, have any other encountered this and fixed it with another printer host?

I am running Mac OS (El Capitan) and both Cura and Pronterface is working just fine. check the baud rate on your lulzbot and make sure that it matches the baud rate in the software. My baud rate is 11520 I think that it’s pretty universal with lulzbot.


If you know how to fix this, perhaps you can let the support team at Aleph know, they seem to know about the baud rate issue, but from what they say, it is not changeable because of Apple’s spyware protection protocol. Alephs response to me was “the service bulletin on El Capitan is up to date” and they gave me this link
As for me fixing it, I do not know how to check the baud rate on my Taz, not would I know how to adjust it or the my computer rate to synch the two.
Thanks for your input

I don’t know if its been suggested, but you could run the printer through a Raspberry Pi using server software like AstroPrint or Octoprint. Its an inexpensive investment and you won’t tie up a Mac running the printer.

I’ve used Octoprint for 98% of the prints on my TAZ5. Slice and upload the gcode. Start the print, monitor via the webcam… all from the comforts of the living room or master bedroom.

Hi kcchen,
Thank you for sharing your experience, having remote access and monitoring would be a big plus I’d imagine. Aleph lists several printer hosts that can be used, Octoprint is among them. I’ve been considering Simplify3d as well, it seems pretty popular and has both a slicer as well as being a host. Any particular reasons why you went with Octoprint over other choices?

I worked on getting the Z axis moving tonight and made some headway. I’ll at least be able to use the GLCD now.

Do most of you who print use your computer or just use the GLCD and card? I’m getting the idea that you can do a lot more with the computer program, so it would be more useful when dealing with more complex print jobs?
thanks all for sharing your experiences with me.

Simplify3D is software to convert STL projects into gcode instruction for the printer. Octoprint streams the gcode to the printer. So they are different components in the workflow.

I run Simplify3D on my laptop to slice / convert the project into gcode then upload the file to Octoprint via a web interface. Once uploaded, print can be started. That’s my typical workflow.

Many folks copy the gcode to the SD card and print without being tethered to a laptop or print server. It mitigates any issues with the laptop… for instance going into sleep/hibernation which would stop the print. The printer basically reads the instructions directly from the gcode file.

If you can get your frame or z-axis sorted out, print the sample files (rocktopus seems to be a favorite first print) from the provided SD card. Once you get the pre-sliced sample gcode files printed, you can move on to downloading/designing project for slicing.

Simplify3D is great for lots of things, but if you can’t talk to the printer with Cura, it’s not going to help. It’s got to do with some changes in the security system. I’m honestly not sure why it seems to hit some people harder than others. I don’t have much issue with it, but others certainly do. I’m on El Cap as well.

IMO, the best thing to happen to my printer was bolting a Raspberry Pi w/camera to it and using Octoprint. It’s great. But if you want to get direct attach printing working you probably can. I think I ended up disabling the new security stuff, installing everything and getting it working, then turned it back on. There are some directions on the net for Arduino and other similar USB Serial devices that discuss it. You have to reboot when changing the security flag. It’s nice to have a way to do it, as I don’t think it’s simple to upload firmware to the printer with Octoprint. Not that you have to do that often, but it’s nice to have the option.

This is a bug in Cura, not a problem with the Mac. Especially since no other Slicer software has this issue.

Plug your printer into the Mac, then in Cura, go into Machine Settings (Machine -> Machine Settings).

Change the Serial Port from Auto to the port that OS X configured for your printer. It should be something like:


The 1421 may be different, but the /dev/tty.usbmodem part should be the same. It should also show a Bluetooth port, which you don’t want.

The baudrate on my version of Marlin is 115,200. On newer versions (TAZ 6?) I think Luzbot changed it to some rediculously high rate.

Cura should work now.

If you do decide to go with Simplify 3D, you won’t regret it. 1000 times better than Slic3r or Cura.


Hey all,
Thanks for the informative responses. Connecting via wifi and Rasp pi sounds like the ticket, not really seeing any rationale for connecting via wire. I am hearing great things about Simplify as a slicer, and my understanding is it is also a “printer host” software, so if I were inclined I could still connect via wire? The loss would be the presets that Luzbot has built into the customized CURA for Taz printers, etc.?

Gapdev, thanks for the info on how to get my Mac to connect. I figured from what I’ve read that there must be a solution given that some with El Capitan can connect, I just lack the knowledge, so thanks for the input.

I work a crazy schedule 13 hour shifts for a week… but then I get every other week off (healthcare). Today is the first day of my work week, so I’ll be playing with this when I have some off time in a week, I’ll let you all know how it works out once I get to try some of this stuff.

These are the machine settings in Cura running on my mac with El Captain. Check the bottom right column.

Just to clarify… The Raspberry Pi running Octoprint would still connect to the printer via USB. The Octoprint (on the Pi) is accessible via Wifi (or wired Etherenet, if you prefer).

I am hearing great things about Simplify as a slicer, and my understanding is it is also a “printer host” software, so if I were inclined I could still connect via wire? The loss would be the presets that Luzbot has built into the customized CURA for Taz printers, etc.?

S3D has a printer host component so you could keep the laptop connected to the TAZ. And yes, you would lose the LB pre-configured profiles for CURA. But they have been translated into S3D for the most part. Just ask the community when you’re ready.

I have held back upgrading to El Capitan for this reason (as well as a few others involving email and music). I actually had to revert a few friends machines back to Yosemite to solve their problems (not printer related) and did fix the email issues of 2 other people.

I use Simplify 3D and love it. I keep my Mac tethered which is not an issue for me since my CPU is set to never sleep (my Mac is also my voice mail for my business and needs to be awake 7/24 to answer calls).

I will probably see what the next upgrade from Apple looks like and decide then if I will upgrade. It seems like Apple OS is getting more hands OFF for the user (like Windows) and I am not a fan of that, I like/need to tinker with the nuts and bolts of the OS. At least with Yosemite I can get around the anti tinkering stuff (show all files, protection off).

Hi tmorris,

I wish I had stuck with Yosemite, it was a fine op sys for me. I don’t mind having it as an op sys, but the process of undoing El Capitan, etc., isn’t exciting. Not something I anticipated as part of 3d printing, but I’ll end up doing something. I may try some of the things mentioned here, though some seem to contradict each other, I’m trying not to be superstitious about it [laughing].

Thanks for the feedback on S3D, I read often that people like the software, the on objection I have read is issues with thin wall printing.


This has some of the info I mentioned.

The board in a lulzbot is basically an Arduino with motor drivers, so the same things apply.

Regarding Simplify3D, it’s great for a lot of things. If you do a lot of thin walls, it’s not so great though. I don’t run into problems like that often, so it works well for me. But if you do a lot of that, I hear Slicer is the best at it.

Hi Kenny,
Following what you advised, the drop down menu on my CURA only offers two options: “auto” and the bluetooth port (i.e., there is no /dev/tty.usbmodem option).
thanks for trying.

Hi Sruggler,
My screen shot would look the same. :slight_smile:

Ok gang, “John Mc” on another thread mentioned that a file must be loaded for the “control” button to activate. I had not done that and I now have my first print :unamused: . In defense of Lulzbot, they do include loading a print as one of the steps in the instructions, a step I bypassed leaping to the calibration stage. Totally my fault. I got the binding issue solved pretty easily just loosening the carriage screws and moving the Z axis (as instructed by support) several times to let the machine find the place of least resistance. That worked. Leveling the bed was kinda fun, a good learning experience.

I printed my first print, the venerable “rocktopus,” but ran out of filament about 80% through. I paused the print when the filament sent from the machine had about an inch left, pulled that piece out and then replaced it with a new roll of eSun abs that I bought when I ordered the printer. I pushed it in and then pressed the “extrude 10” button till it was feeding, removed the string from the nozzle and pushed “resume.” unfortunately, I shifted the print head when changing out the filament, so it started back in the wrong place, but still another learning experience, so it’s all good. The carriage release is something I’m still trying to master. What did print was great. Sticking was perfect, and the print and process were fun. A very elegant machine!