El Capitan?

Just unboxed the Taz 5 and learned that it won’t talk to my MacPro running El Capitan. So I can’t level the bed or any of the typical setup stuff. Any idea when a software update might be forthcoming?

I have no knowledge about Apple OS, but the driver for the printer is basicaly a simple USB to serial converter so I’m confused there are problems…?

But you don’t need USB connection to the printer while you are waiting for an update. Everything can be controled by the LCD Screen and rotary encoder. Use the menue to move the axis for calibration and print from SD-card is what I would do.

Agreed. There is no reason I know of that the TAZ wouldn’t connect to El Capitan. I use OSX just fine. Are you connecting through Cura or Pronterface?

Hello MFettinger,

What version of CURA are you using?

Does CURA give you any error messages?

Have you tried any other computers?

Thank you,

To answer your questions: I am using Cura 10.17 Cura does not give me any error messages, there is just no “control” choice after you load a model. Yes I brought in an older 2010 MacPro running Yosemite and it connected just fine, so I have been using it to all the intro stuff.
Once it is set up I plan on just using the SD card for a majority of printing. I’ll have to memorize the menu in the LCD module, is there a flow chart anywhere on the website that lets me visualize menu structure.
Just as a side note, on the new MacPro I plugged the USB cord in to a USB 3.0 hub, Apple Display USB Port and directly on the machine to no avail.

Have you tried the v18 beta (https://forum.lulzbot.com/t/cura-lulzbot-edition-v18-beta/2518/1) available here : http://devel.lulzbot.com/software/Cura/Test/
It’s working fine on my OSX El Capitan. If you don’t see the control button and only see a “save to GCode”, it means that it doesn’t detect any serial ports on your machine, but that shouldn’t be the case because there are no drivers to install, Mac OSX has native support for it.
Also, check the list of serial ports in the machine settings to see if there’s anything listed there.

Also, check the list of serial ports in the machine settings to see if there’s anything listed there.

Definitely check this. I had this problem when I had first installed Cura on my MacBook Pro. I had found that it defaulted to a Bluetooth connection. Once I changed it to a serial connection, the CONNECT button was there.

Thanks for the suggestions, where did you find those settings on your Macbook Pro? I’m looking in system settings and all I saw were bluetooth serial ports without the Taz 5 being listed.

Then check the drop-down for COMMUNICATION SETTINGS > SERIAL PORT (lower right side of pop-up)
Mine will only show AUTO or “INCOMING BLUETOOTH…” unless a printer is connecting via USB, and then a serial port is listed as an option.

Success, the Taz 5 is finally talking to the 2015 MacPro running El Capitan. It was a strange turn of events, I couldn’t get the Matter and Form scanner to work either so I unplugged every USB connection except the keyboard and the scanner, it worked and installed the software. Then strangely enough when I opened Cura it showed the control button without the Taz 5 plugged in. So I clicked on it and then plugged in the Taz 5. No connection, so I went to machine settings in Cura and tuned off auto on the serial port menu. I then just started going down the line of different modem options in the dropdown list. /dev/cu.usbmodem2441 worked and I left the baudrate on auto. I can’t explain why it works only that it does.

I have a Mac Book Pro with El Capitan and I run Simplify 3D and my MakerGear M2 off it without problems. To be honest I never tried it until last week as I use Windows 7 Pro 64 bit on a laptop to run the 3D printer 99% of the time. I think the TAZ and MakerGear use the same controller board.

George, was your system fresh installed with El Cap or was it upgraded to it? Could you provide a few details about the hardware too?

I am assuming it was a fresh install as I purchased a off lease Mac. It runs Simplify 3D the Mac version just fine and my printer is a MakerGear M2 running off USB but I do print most of the time off the SD card.

Are you using Cura LulzBot Edition at all? I’m trying to debug the specific case of Cura LE (running on OS X El Capitan) not being able to connect to a printer.

I have a cleanly installed Macbook Pro (2012) on El Cap running Cura LE, the last beta at the moment. I am planning to download the latest release version tonight. My setup works and prints fine with a Mini. If there is information I can provide, let me know. This latest OSX seems to have caused problems for a lot of people, so you might try some of the things people suggest on various sites regarding OSX and USB-Serial devices. It seems mostly related to custom drivers not being signed though, and I didn’t need to install any drivers for the Mini to work.

For people that ARE experiencing this problem on OS X (El Capitan specifically): could you tell us a little info?

  1. plug in your printer to the OS X machine and power both on.
  2. Open Cura
  3. List what options you have available in the Serial Port section of the machine settings window
    Bonus points for posting a screenshot :stuck_out_tongue:

We’ve issued a service bulletin here referencing this issue. We are working on a fix, but we could use more information and screenshots from those affected.