Cura 20.01 won't go past splash screen.

Hi Guys,

Microsoft Surface Pro 4 (brand new fresh install, fully patched).

Cura splash screen runs, i get the wizard, click finish then nothing.

Pythonw.exe still running in task manager. Kill it, try Cura again, same as above but no wizard.

Tried Cura 15, no issues at all.

output_log

Traceback (most recent call last):
  File "c:\Program Files (x86)\Cura_20.01\python\lib\site-packages\wx-3.0-msw\wx\_core.py", line 16766, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "Cura\gui\app.py", line 182, in afterSplashCallback
    self.mainWindow = mainWindow.mainWindow()
  File "Cura\gui\mainWindow.py", line 216, in __init__
    self.normalSettingsPanel = normalSettingsPanel(self.leftPane, self.scene.sceneUpdated)
  File "Cura\gui\mainWindow.py", line 729, in __init__
    self._addSettingsToPanels('basic', left, right)
  File "Cura\gui\mainWindow.py", line 762, in _addSettingsToPanels
    configBase.TitleRow(p, _(title))
  File "Cura\gui\configBase.py", line 107, in __init__
    self.title.SetFont(wx.Font(wx.SystemSettings.GetFont(wx.SYS_ANSI_VAR_FONT).GetPointSize(), wx.FONTFAMILY_DEFAULT, wx.NORMAL, wx.FONTWEIGHT_BOLD))
  File "c:\Program Files (x86)\Cura_20.01\python\lib\site-packages\wx-3.0-msw\wx\_misc.py", line 165, in GetFont
    return _misc_.SystemSettings_GetFont(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "wxFontEnumerator::IsValidFacename(font.GetFaceName())" failed at ..\..\src\msw\settings.cpp(301) in wxSystemSettingsNative::GetFont(): 
Traceback (most recent call last):
  File "c:\Program Files (x86)\Cura_20.01\python\lib\site-packages\wx-3.0-msw\wx\_core.py", line 16766, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "Cura\gui\app.py", line 182, in afterSplashCallback
    self.mainWindow = mainWindow.mainWindow()
  File "Cura\gui\mainWindow.py", line 216, in __init__
    self.normalSettingsPanel = normalSettingsPanel(self.leftPane, self.scene.sceneUpdated)
  File "Cura\gui\mainWindow.py", line 729, in __init__
    self._addSettingsToPanels('basic', left, right)
  File "Cura\gui\mainWindow.py", line 762, in _addSettingsToPanels
    configBase.TitleRow(p, _(title))
  File "Cura\gui\configBase.py", line 107, in __init__
    self.title.SetFont(wx.Font(wx.SystemSettings.GetFont(wx.SYS_ANSI_VAR_FONT).GetPointSize(), wx.FONTFAMILY_DEFAULT, wx.NORMAL, wx.FONTWEIGHT_BOLD))
  File "c:\Program Files (x86)\Cura_20.01\python\lib\site-packages\wx-3.0-msw\wx\_misc.py", line 165, in GetFont
    return _misc_.SystemSettings_GetFont(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "wxFontEnumerator::IsValidFacename(font.GetFaceName())" failed at ..\..\src\msw\settings.cpp(301) in wxSystemSettingsNative::GetFont(): 
Traceback (most recent call last):
  File "c:\Program Files (x86)\Cura_20.01\python\lib\site-packages\wx-3.0-msw\wx\_core.py", line 16766, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "Cura\gui\app.py", line 182, in afterSplashCallback
    self.mainWindow = mainWindow.mainWindow()
  File "Cura\gui\mainWindow.py", line 216, in __init__
    self.normalSettingsPanel = normalSettingsPanel(self.leftPane, self.scene.sceneUpdated)
  File "Cura\gui\mainWindow.py", line 729, in __init__
    self._addSettingsToPanels('basic', left, right)
  File "Cura\gui\mainWindow.py", line 762, in _addSettingsToPanels
    configBase.TitleRow(p, _(title))
  File "Cura\gui\configBase.py", line 107, in __init__
    self.title.SetFont(wx.Font(wx.SystemSettings.GetFont(wx.SYS_ANSI_VAR_FONT).GetPointSize(), wx.FONTFAMILY_DEFAULT, wx.NORMAL, wx.FONTWEIGHT_BOLD))
  File "c:\Program Files (x86)\Cura_20.01\python\lib\site-packages\wx-3.0-msw\wx\_misc.py", line 165, in GetFont
    return _misc_.SystemSettings_GetFont(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "wxFontEnumerator::IsValidFacename(font.GetFaceName())" failed at ..\..\src\msw\settings.cpp(301) in wxSystemSettingsNative::GetFont(): 
# Generating comtypes.gen._683BF642_E9CA_4124_BE43_67065B2FA653_0_1_0
# Generating comtypes.gen.TaskbarLib
Traceback (most recent call last):
  File "C:\Program Files (x86)\Cura_20.01\python\lib\site-packages\wx-3.0-msw\wx\_core.py", line 16766, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "Cura\gui\app.py", line 182, in afterSplashCallback
    self.mainWindow = mainWindow.mainWindow()
  File "Cura\gui\mainWindow.py", line 216, in __init__
    self.normalSettingsPanel = normalSettingsPanel(self.leftPane, self.scene.sceneUpdated)
  File "Cura\gui\mainWindow.py", line 729, in __init__
    self._addSettingsToPanels('basic', left, right)
  File "Cura\gui\mainWindow.py", line 762, in _addSettingsToPanels
    configBase.TitleRow(p, _(title))
  File "Cura\gui\configBase.py", line 107, in __init__
    self.title.SetFont(wx.Font(wx.SystemSettings.GetFont(wx.SYS_ANSI_VAR_FONT).GetPointSize(), wx.FONTFAMILY_DEFAULT, wx.NORMAL, wx.FONTWEIGHT_BOLD))
  File "C:\Program Files (x86)\Cura_20.01\python\lib\site-packages\wx-3.0-msw\wx\_misc.py", line 165, in GetFont
    return _misc_.SystemSettings_GetFont(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "wxFontEnumerator::IsValidFacename(font.GetFaceName())" failed at ..\..\src\msw\settings.cpp(301) in wxSystemSettingsNative::GetFont():

Need help! Thanks in advanced.

To Add the the above, I only get the output_log messages when i run the cura.bat file from commandline and terminate the batch file when nothing displays.
Doesn’t seem to generate anything when run from the shortcut.

Same behaviour in 19.12, 19.08, 18.03.

17.10 works perfectly fine.

Looks like https://code.alephobjects.com/T434 is describing my issue.

I have exactly the same Problem! Did anybody nows how to fix that?

Microsoft Surface Pro, 2 Days old, full patched.
Lulzbot Mini also brand new

When starting Lulzbot-Cura 20.01, Cura starts green Starterpic. then splashs and nothing start.

No Problems with my MacBookAir started inside Win10 Mode with Lulzbot-Cura 20.01

Last 2 Days i try to read about that Problem but i dont found a resolution.

Cura Bat. listen This:
load preferences from C:\Users\3D User.cura\20.01\preferences.ini
Failed to listen on port: 49674
Listening for engine communications on 49675

Hope somebody can help to fix that.
Thanks a lot

Our software team has developed a test version that they believe would solve your issue. Specifically the 20.02-104c0 version available here > https://devel.lulzbot.com/software/Cura/Test/

Thank you, Lulzbot-Cura 20.02 works fine.

I tried this, and I am still having the same issue, any tips?