Cura and STL File Size Limit

Is there a limit to the size of the STL file (in Megabytes) that Cura can load?

I have loaded and printed STL files up to 10 MB so far, but am considering some projects that have STL files of 140 MB.


Anyone know the limit?

It depends on how you are sending it, If its from the computer you may be able to send larger ones. If its from the SD card you may be limited by the onboard buffer, whatever that is. Look up the Rambo specifications, it should say.

Ecstatic Mini Owner. I am using a digital texturing program on my models - to disguise the observable layering mostly. My initial experiment worked very well. Second one, ok. Third one is 973 meg. I try to load thru Cura and nothing happens - no error message, no cpu or memory usage. I can live with limitations, but I’d really like to know specifically (or close) what those are. I can see stl file size as a limiting factor, same with windows/linux platform preference, and/or polygons in the model. It is also possible that Cura knowledge on this forum may be lacking regarding this arcane bit of specification - if there is a better, more relevant forum, please advise.

Obviously, I can cut my models up, but would prefer not to do that. Thanks all.

I think the printer reads X lines of gcode at a time from the SD Card, so you could have a very large gcode file printed. I have seen that Windows has an issue working on large files if you do not increase the swapped file space that it defaults to. I use to convert very large video files, and it would just stop - giving no errors or output! The file being large will be worked on a piece at a time usually, as much of memory is taken up by running programs - thus the swapping. I am not sure how good Python is in memory management on large files.

Pierset - where do I find the Rambo specifications?


I too would think gcode files would have no size limiting factor since they are read line by line. Not sure about STL or OBJ files though.

Are you asking about cura being able to open large STL files at all or printing from large STL files after they have been opened? I have a very large OBJ file that loaded in cura though it took several minutes to show up. I have not tried printing it yet. I can give you a copy of it to test if you want. Though it is only 24.4mb not 124…

If it’s about cura opening them in the first place i would think it would be more about your computer memory size and swap space. On Linux systems swap space can be increased easily with partition editors. At that point its basically the same as heavy graphics work, you might need a computer with lots of memory, a good graphics card, and a 64bit operating system would be good too, though i don’t think anyone uses 32bit Operating Systems anymore.

Based on my experience running the 64 bit Lulzbot version 21.02 of Cura on Windows7 and Windows10 both with 16Gb RAM it lets me load up to about 150 to 180 MB of STL files when trying to fill the platform with multiple smaller sized STL files. It will just stop slicing when another object above that size gets loaded.
FYI using the Ultimaker Version of Cura ( V2.3.1 ) on the same computers and loading the same object multiple times I went over 500 Mb total size and it still was slicing away without problems (also sliced faster than the Lulzbot version ) and likely could have loaded even more.