STL file to large for Cura?

I have a TAZ 6 and I’m using Cura Lulzbot Edition 3.6.20. It works great but sometimes I create stl files that are on the larger side. Right now I’m trying to print parts for a ship model and when I load the stl file (it’s 262,592 KB) for the latest part into Cura I get an “Invalid file” error. I know the stl is valid as I can view it in other stl view apps (i.e. 3D Builder). Is there a way to see what the maximum file size that Cura supports. Also are there any tips to get Cura to accept this file or is there another slicer I could try for this?



I’d try Ultimaker Cura. While they don’t have built in profiles for LulzBot printers, it’s pretty easy to start with a custom printer and copy over what you need from CuraLE.

If you still have problems, there are other slicers that could be tried.

Depending on the complexity of the file, Cura LE eventually runs out of memory causing the “invalid file” error. Usually this behavior is seen after loading multiple high complexity models and is fixed by restarting cura. If the STL is overloading Cura LE’s memory from the get go then you will need to slice it with a different program.

What program are you using to make the STL? Would it make sense to reduce the quality of the STL and still get the same quality of print? Basically… less triangles?