Cura LE Only works when ran as Admin... Help?

Good Morning, here’s my issue. I’m an IT guy for a company and they need these two users to be able to use the cura software to get work done. I installed the application as normal and under their user account but typed in my admin credentials when prompted. After the installation is complete, the software will open as normal. But once the software is closed so that the other user on second shift can do his job, Cura would open with the initial loading screen, load to 100% and then close. This also started happening to the first user when he tried to get back on! Now no one can use it. The only way that it can run properly is if i ran the app as an admin. This creates an issue because we don’t just give anyone administrator rights onto our network. NOW! I have already tried granting the users FULL CONTROL via the properties tab of the CURA software, but that did not resolve the issue. Please help if you can. All suggestions are appreciated. Thank you. If you would like to email me directly, Contact me at
-Respectfuly Submitted, Julio Munoz

I have noticed an issue that when cura doesnt want to reopen it is generally because a process is still running that should have been shut down. To fix the issue I open task manager find a process that is something like slicer for cura and end that task. After that cura opens up just fine for me. The other options are reinstalling cura or checking %appdata% and looking at the log files under both of the cura folders. Let me know if that helps.

1 Like

Turns out the profile of the worker got courrupted. Not sure how. But we deleted his profile out of the computer and had him log on to the machine as if it was the first time. Everything works now. Thank you for your help.