Cura doesn't run

I’ve been running Cura version 3.6.31 and earlier versions for years on my windows 10 computer. Suddenly it would not run anymore. I finally gave up and uninstalled it and re-installed it (I have repeated this process 4 times). Since the original installed version was working and suddenly stopped working, I suspect that something else is going on.

The Cura rocktopus window opens and runs to “loading interfaces” and then disappears. Nothing else ever appears. I looked in task manager and “Slicing engine for Cura” is a background process. Nothing else Cura related is running.

Does anyone have any ideas on how to get this to run?

Could try deleting the cache directories. Follow the instructions on this page under “Upgrading? Clear Your Cache!”

Usually I run my dedicated win 10 laptop off-line so Microsoft doesn’t interrupt my prints with their update crap. One day Cura was running fine and then I made the mistake of going on-line.
Cura would not start again. I tried everything. What I found out is Microsoft just wants you to upgrade to win 11. So any/all “non-approved” software stopped working. Although the upgrade was “free”, they take every opportunity to up-sell you. I am seriously looking at Linux distributions to get away from MS.

I got it to finally run. I skimmed over the part of the instructions the say to clear Cura directories in %appdata% and %localappdata%. My bad.

BTW, the latest Cura LE version has changed from 3.6.31 to 3.6.33. I don’t know what changed.