Cura LulzBot Edition v18 Beta

Major new feature:
PAUSE [╯°□°]╯︵ ʎןןɐuıɟ

Here’s a little demo we did with 4 different colors of PLA. The design is called ‘Matterhorn 1:30000’ by jawensi. Check it out!
Photo by Ben Malouf

Excited to hear how everyone uses pause. Detailed list of changes here:

Known issues:

How to provide feedback:

Where to provide feedback:

Download here:

Happy testing,


Cool will have to try it, but i have to login to Phabricator to get the changelist?


Beta started: 2015-11-23 (͡◕‿◕͡)
Based off Ultimaker’s 15.02.01 version of Cura

-While printing over USB, any ongoing print can be halted. This will allow you to:
-Change filament color
-Swap spools before running out of filament
-Embed an object inside the print
-Clear partial nozzle clog
-Inspect internal structure of print
-Prime the nozzle at the start of a print
-Feed filament by hand or click the extrude/retract buttons
-More detailed print progress indicator
-Title bar of print window shows a percentage as well as current Z-height

-[Windows] several installation problems
-Notification messages are shortened instead of not displayed when there is too much text
-A significant number of minor cosmetic and labeling items
-Slow down filament feed rate for Flexystruders (say that three times fast) when clicking extrude/retract to prevent jamming

Quickprint Profiles

Several new materials have been added:


  • Bronzefill
    -ChromaStrand: INOVA-1800

Sorry, about that Logis. All fixed now.

Thanks nbmoretto!

Yes Please!

“You don’t have permission to access /software/Cura/Test/Cura_18.01.exe on this server.”

OS X and Windows file permissions have been fixed now.

confirmed, thanks!

Windows 10 here, first time using pause failed when trying to resume. However, I have tried it twice since and both times it worked well! Would there be a way to pause at a certain layer or Z-height with this feature? I am already working on a neat project using this pause command to switch colors. :slight_smile:

In what way did it fail the first time?

If it’s not possible in Cura, you could work with the M600 command if you have filament change option enabled in Marlin. Then simply search for the G1 Zx value you want in Gcode and insert the M600 command.

Yes, switch to expert settings, then go to the plugins tab and add the “pause at height” plugin. You can add it any number of times to pause at multiple heights.

Same error as here:

How can I bring up the error log in the command prompt so I can give you more information if it happens again (like in the first image in the link above)?

Thanks! I have a Mini and unfortunately I don’t think this plugin works since the Mini has no LCD touch screen to tell it when to resume. :frowning: Is this true?

Would be awesome if you guys integrated that pause at Z pluggin with the new pause command in Cura Lulzbot Edition v18!

Having problems again, here’s the error log:

Recv: ok
Recv: ok
Recv: ok
Send: G91
Send: G1 E10.0 F120
Send: G90
Recv: ok
Recv: ok
Recv: ok
Send: M83
Send: G1 E1.500000 F120
Send: G1 E-1.500000 F120
Send: G1 X56.428000 Y11.440000 Z2.225000 F1800
Send: G1 E1.500000 F120
Recv: ok
Recv: ok
Recv: ok
Send: G1 F1800
Send: G92 E574.319010
Send: M82
Recv: ok
Changing monitoring state from 'Paused' to 'Printing'
Send: M105 T0
Send: N7117G1 X56.428 Y11.440 E574.31901*115
Serial timeout while writing to serial port, trying again.
Serial timeout while writing to serial port, trying again.
Unexpected error while writing serial port: SerialTimeoutException: 'Write timeout' @
Unexpected error while writing serial port: SerialTimeoutException: 'Write timeout' @
Changing monitoring state from 'Printing' to 'Error: SerialTimeoutException: 'Write time...'
Connection closed, closing down monitor

This happened two prints in a row. I’ll keep testing.

No need, I can reproduce the error and I’ve been working to fix it. I think we’ll release a second beta with a fix for this serial issue on Windows.

It will work with a Mini as well, even without an LCD. Once the pause happens in the plugin, the UI will show you as paused and you can resume it by pressing the resume button in Cura instead of using the LCD. It didn’t work before because Cura didn’t support Pause/Resume itself, but now it should be fine. If you have issues with it, let us know, that’s what the beta is for :slight_smile:

Oh awesome! I’ll give that a try. I also ended up teaching myself some GCode to manually insert some pause commands to allow me to change filament colors in a print! :slight_smile:

Looking forward to trying the new beta out!

New build 18.03 is now available. This fixes:
Windows issue conflicting with another python program reported here:
Windows resume issue caused by
OS X crash

Try them out from here:

Happy testing,

I first had to use the windows version, due to problems with a missing prerequisite (python-wxgtk3.0) under my preferred Ubuntu. The pause worked great and is much appreciated.

Then I found this workaround for the prereq. My issue is that Ubuntu 14.04LTS doesn’t have support for python-wxgtk3.0, which is in 14.10. I found this description, , of a ppa with just the python-wxgtk3.0, that I installed easily and then got this 18 beta to run under Ubuntu.

(I’m a brand new Taz5 user. I’m very happy with the results I’ve gotten, right out of the box)

v18 has now been publicly released. Please get it from Thanks for everyone’s help in testing!

mrsoft99, appreciate the debugging effort you went through, thanks for reporting it, I’ve made a bug report for that one.