Cura z height adjustment

I normally use Simplify 3D as my printing software but sometimes I still have issues with print quality. I have tried Cura a long time ago but since it’s been updated and Lulzbot has made the profiles for it I thought I would try it again.

So in the past I always had an issue with Cura that it seems to home the Z axis then move up a tiny amount before printing (but that is just a guess) and the new version is as well.

Here is my issue, with Simplify 3D I have my Z axis dialed in super perfect, I have no problems with getting ABS to stick yet a little tap on the parts when cool removes them (so I really don’t want to mess with the Z axis end stop adjustment).

Cura, the parts don’t stick hardly at all and will come off the bed mid print. I don’t know if it’s raising the nozzle above the Z home before printing or if the first layer is not thick enough?!?

Any suggestions other than adjusting the Z axis end stop?

Almost forgot. TAZ 5, .35mm nozzle ABS

Could be something in the startup script.

You could also try a negative Z-offset as a quick fix.

I think you exactly right.

Every time I load a new version of Cura I have to go in there and edit the Start Gcode.

Like today I loaded version 19.12-0054 and looking in the start Gcode there is no home axis command. Therefore it starts printing at the height that the z axis was left off the bed.

Here is the original code:

;Sliced at: {day} {date} {time}
;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
;Print time: {print_time}
;Filament used: {filament_amount}m {filament_weight}g
;Filament cost: {filament_cost}
;M190 S{print_bed_temperature} ;Uncomment to add your own bed temperature line
;M109 S{print_temperature} ;Uncomment to add your own temperature line
G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off

G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops

G1 Z15.0 F{travel_speed} ;move the platform down 15mm

G92 E0                  ;zero the extruded length
G1 F200 E3              ;extrude 3mm of feed stock
G92 E0                  ;zero the extruded length again
G1 F{travel_speed}
;Put printing message on LCD screen
M117 Printing...

Why is there a G1 Z15 to move the Z axis right after you set it to zero? My prints stick better when they aren’t 15mm above the bed.

Here is my corrected startup.

;Sliced at: {day} {date} {time}
;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
;Print time: {print_time}
;Filament used: {filament_amount}m {filament_weight}g
;Filament cost: {filament_cost}
;M190 S{print_bed_temperature} ;Uncomment to add your own bed temperature line
;M109 S{print_temperature} ;Uncomment to add your own temperature line
G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off

;G28 X0 Y0  ;move X/Y to min endstops
;G28 Z0     ;move Z to min endstops

;G1 Z15.0 F{travel_speed} ;move the platform down 15mm
G28    ;Commented out the above lines and issue a G28 command to home all axis before printing. 

G92 E0                  ;zero the extruded length
G1 F200 E3              ;extrude 3mm of feed stock
G92 E0                  ;zero the extruded length again
G1 F{travel_speed}
;Put printing message on LCD screen
M117 Printing...

And you might want to comment out the G1 F200 E3 ;extrude 3mm of feed stock also to keep it from extruding 3mm of filament before it starts on the skirt around your part.