Custom material settings not obeyed

I’m running Cura v 3.6.36. I’ve slightly adapted one of the built in ABS settings to my own Custom material, and set the extruder temperature at 225C.

But when the print starts, it is showing 250C, the filament is too hot, and constantly ‘leaking’ out of the nozzle. And not sticking to the bed, either.

I’ve just changed the filament colour from orange to white, and the orange was printing absolutely fine, but the white is not. Both are ABS, and have previously worked fine using the same Custom material.

I’ve tried changing the temperature setting from 225C to 230C and restarted the print. No change. It’s still heating to 250C.

I don’t see an option to Save the custom setting, just Close after making the change.

What am I missing?

A variant question.

How do I set the hot end temperature for the next print after loading a material?

Cura has several different material temperatures, one for softening, one for wiping, one for probing, one for initial (first layer) and one for second and subsequent layers. You can either check each one in Cura, or simply open and edit the gcode in Notepad.

Thanks for the suggestion. But I feel I ought not to need to do that.

My custom material is based on the built in ABS (IC3D). The only change I made is to the Default Printing Temperature, which was 240C in the original. I changed it to 225C.

But it made no difference - when the print starts, the printing temperature is still 250C.

There is NO setting in the Preferences/Configure Cura/Materials/Print Settings showing a temperature of 250C so where is that high temperature being set, and overriding the Material setting?

How do I view the G-code being produced, to (perhaps) see where this is coming from?

PS. To check if my settings were being read from the settings I made for my custom material, I also set the probe, soften and wipe temperatures to a few degrees different from the original and also from each other. They WERE respected when Print started. So why is the Print temperature not being read from the custom material print settings?

It sounds like it’s your first layer temp that hasn’t been changed.

To examine your gcode, just export the gcode to a file and open that file in a text editor. You’ll be looking for “M109 S250” commands for 250c temp settings on the hot end.

That’s a helpful clue.

I’ve never seen any setting for first layer temperature. Where can I change it in Cura?

And if I changed it by accident, how did I do that?

This only started (coincidentally I think) a few days ago when I changed filament colour.

I kept all the same settings, but Cura suddenly changed the print temperature - and not I think just for the first layer, though I aborted the print soon afterwards as it wasn’t sticking to the bed.

Print temperature seems stuck at 250C.

I’m baffled about two things:

  • where did the 250C come from, and why? It was previously reading 225C from the Material Print Settings
  • why is the Default Print Temperature in the Material apparently being ignored? Cura is reading the other temperature setting for the preliminary bed levelling process (170C) when I changed it by a degree or two to check that editing the material did make a difference.

In the material settings:

If you don’t see it there, you need to be in the custom side, and if it’s still not visible, go into settings and enable it:

I can’t tell you how you changed it, there’s many ways in the profile setup that Cura uses.

Many thanks. I’ll look for that.

Well, I’ve only just found the time to revisit this.

And ALL the settings were made visible, but this one wasn’t, and I still can’t find a setting to 250C anywhere.

But after this lapse of time, two restarts of the computer and a couple of Cura, things have gone back to normal - and I STILL have no idea what setting changed, or what fixed it,

But fixed it is, at least for the moment!

And unfixed again this morning showing 250C as the printing temperature again.

Will have another look in the Settings, but I haven’t found any setting not visible, nor any set at 250C

Attach your gcode so we can see where it is being called out

Happy to do that, but how do I find the Gcode to copy and upload it?

Is it as simple as selecting Save to File instead of Print in Cura, after the slicer has finished?

Yes, save to file, then upload. Preferably a small, simple object.

I’ve been busy on other things but returned to this issue today.

I attach the gcode for a simple square 10mm x 10mm with a 5x5mm square hole in the centre and 2mm thick. I printed it using a Brim, 20% fill

I chose a custom material with the default print temperature set to 230C, duplicated from the built in ABS (IC3D) with only this parameter changed from the original.

The nozzle is still heating to 250C.

I still don’t understand where this setting can be coming from. Maybe the gcode will tell you?

I can only see one line (65) with 250 in it.

LM_Test piece.gcode (21.1 KB)

Here are my custom material settings:
Capture

In Settings/Settings Visibility, I have the Check All box ticked so all settings should be available to view.
WHERE can I view what these temperature settings are established?
Capture2

Is Printing Temperature the one that is setting 250C? If so, where can I change it? And how did it get set to 250C in the first place?

[LATER]
Looking in Settings/Profiles I can see settings for Printing Temperature, but these are set at 245C.

And scanning all the Settings I still can’t see where the 250C is coming from. And it’s too hot!

I’ve updated Cura from 3.6.36 to 3.6.40 but it has made no difference. And restarting both computer and printer (which temporarily fixed things a couple of weeks ago) had made no difference either.

I’ve got the test piece to print at 230C ony by editing the R250 value in the gcode file to 230.

But this isn’t a workable solution for regular printing.

I still have no idea what’s causing the Custom material settings to be overridden.

Have tried printing another item - a knob about 25mm diam.

Saved the gcode, edited the printing temperature in line 65 again, saved, then loaded the gcode file.

Starts printing apparently normally, prints the skirt and a couple of layers of the knob, then just stops. No console message. No error message. No movement of the print head.

Clicking Pause then Resume does nothing.

I’m giving up for the moment. I have NO idea what’s going on, either with the temperature, or with the printer stopping.

I thought perhaps I’d truncated the gcode file when editing in Notepad++ but that appears not to be the case.

I’ve checked that the gcode file appears complete (here are the last few lines of the file):

M84                                       ; disable steppers
G90                                       ; absolute positioning
M117 Print Complete.                      ; print complete message

M82 ;absolute extrusion mode
M104 S0
;End of Gcode

PS.

I wonder if it would help to delete all of the installation and any customised files and start a clean install of v3.6.40?

I have noted the Z-offset and Esteps values that seemed to work well before things went wrong.

Where are my customised files stored on Wn 10?

I have no other ideas myself of what has gone wrong, why my working settings suddenly changed and won’t change back.

Nor why the printer just stopped on the last couple of print attempts.

It hasn’t lost connection.

The computer hasn’t powered down (no power saving setting to do that).

I didn’t click the Pause or Abort Print buttons by accident.

I didn’t jiggle the USB lead to disconnect it.

—-
Help, please!