Does the taz pro have a hot end timeout?

So there’s nothing in the code for Marlin that excludes the Pro from having a hotend idle timeout.

/**
 * Hotend Idle Timeout
 * Prevent filament in the nozzle from charring and causing a critical jam.
 */
#define HOTEND_IDLE_TIMEOUT
#if ENABLED(HOTEND_IDLE_TIMEOUT)
  #define HOTEND_IDLE_TIMEOUT_SEC (15*60)    // (seconds) Time without extruder movement to trigger protection
  #define HOTEND_IDLE_MIN_TRIGGER   150     // (°C) Minimum temperature to enable hotend protection
  #define HOTEND_IDLE_NOZZLE_TARGET   0     // (°C) Safe temperature for the nozzle after timeout
  #define HOTEND_IDLE_BED_TARGET      0     // (°C) Safe temperature for the bed after timeout
#endif

Other parts of the code have ways to exclude certain models in the code, such as:

#if ANY(MiniV2, TAZPro, TAZProXT, Sidekick_289, Sidekick_747)
  

So this isn’t the fault of LulzBot, generally, but I feel like identifying this problem and pushing a fix to the main Marlin fork would be expected.

While not being experienced enough in programming to debug it thoroughly, I suspect that it has to do with the Z steppers holding this gantry in position that is being seen as motion, which keeps resetting the timeout, thus preventing the hot end from cooling down. You’ll notice that the Pro will disable the X/Y steppers (causing them to go to ?s for coordinates), but the Z never does.

1 Like