hotend no longer heats up

not sure what’s going on: my taz worked for all of 3 prints before the hotend began to stop heating up, at all.

if i plug the power resistor into where the bed is usually connected, it’ll begin to heat up. i even tried the following change in the firmware, around line 1330 in pins.h:
//edited here to make heater on extruder connect to heater 1 port instead
#define HEATER_0_PIN 7
//was 9
#define TEMP_0_PIN 0

#define HEATER_1_PIN 9
//was 7
#define TEMP_1_PIN 1

am i missing something, or did i just buy a very expensive paperweight?

I’m beginning to wonder… While probably not related. My Bed and controller went back to Lulz. The problem I was having was that the bed would heat up to the correct temp and then it would immediately show that it was cooling, but it was not, it was still heating and because printrun was seeing a cooling temp, it was commanding the bed to continue to heat.

I could get the bed to re-heat to the specified temp, if I lowered the bed temp to something lower than the probe was reading (remember it was wrong), and letting it run for a couple of cycles, then specifying a new bed temp, would cause it to heat right back up to where it should have only to repeat the process all over again.

I’m beginning to wonder if either a) they got a bad batch of Rambo boards, or b) there is a bug somewhere in the firmware.

Especially where you could connect to a different port and have it heat up. Something broke somewhere either firmware or board.

I hope to know about mine this week, they should have got the board and bed on Saturday via usps… Again, the 2 things could completely be unrelated, but it’s very strange both things have to do with thermistor function of the rambo board. My nozzle has always been dead nutz on both in what it reads and what the software sense, it was just the bed in my case that whacked.

Very odd indeed.


I had this issue as well.

When plugged into the bed heater, the extruder heated up fine.

I traced my issue to a blown fuse on the rambo.

I ordered a few of these:

Once replaced, everything worked as normal.

Renesis, thanks for the info. :slight_smile:

I just recently started having an issue with the bed not heating up passed 80 deg…I will check the fuse.

1013: With the power unplugged, pop off the cover to your electronics and see if you see any obvious wiring issues.

so how is this happening?

Here is what happens/ed on mine.

a) cold unit, turn on bed heat to 110C (doesn’t matter the temp, could be anything), it would run right up there in about 15 mins and hit the temp, reading the correct sensor values in printrun. Then it would say that the bed was cooling and it would show a temp in printrun cooling down to about 70ish and then start to go the other way showing a rise in temp.

b) if you lowered the temp it was suppose to hit, to something lower than what printrun was actually reading, let it run for a few cycles as it showed a lowering trend and turned off the bed, you could then set a higher temp and it would run right back up to it, at which point the whole process would need to be repeated…

My first exposure to this felt like the bed wouldn’t heat past 80C as well… That’s why I spent a whole weekend mucking with it, until I finally sent it back (the bed and controller) so that the gang at lulz could look at it.

if I had it at the moment, I’d try something… build the firmware with eeprom enabled, init to defaults with the M command, save that with the M command and the reboot and then I’d either… a) rebuild for no eeprom and see how it behaved, or b) leave it with eeprom enabled and see how it behaved.

I’m beginning to wonder if there was a software offset that was somehow getting involved (even though eeprom and pid for the bed are not enabled on the default build) and that it’s getting this offset from the eeprom somehow…

When I saw your command about not heating above 80C, it reminded me that mine felt the same way until I figured out the cycle that could make it go above 80…

If on a cold startup it won’t go above 80, then most likely you should get with the gang at lulz and have them check out the power supply… that’s about all it could be unless there is a fuze somewhere and that would show as an all or nothing, not a partial (80C) thing.


just checked my bed temp…its at 114 deg C (from a meter and thermocouple), even though the software is showing it at 84 deg C…strange.

all electronic connections look good.

yep, and I’ll bet you one other things… try this…

a) let everything cool down to ambient. power down, let set, then power back up
b) set 85C as the bed temp and click set.
c) look inside your controller box or pull the top cover so you can see the LED turn on for the bed. It should go on within a second or two of you hitting the set button.
d) now watch, I’ll bet your bed will heat right up to where you set it and you’ll also notice the LED turn off… wait a few seconds/minutes and …then printrun will show it cooling, but the LED will turn back on and stay on - the bed is heating again because printrun is seeing a falling temp. If you watch your themocouple, you should see the heating up start.
e) now if you really want to have fun… try this…
f) set the bed temp to 65C and the LED will turn off and the bed will cool to 65C, you should see it start to cool on your thermocouple as well
g) once you get to 65C… let it rest there for a bit, it will hold that just fine, you should see the LED turn on and off as the bed holds 65C…
h) now set the bed temp to 85C again and I"m betting it will run right back up to 85C and the whole process will need to be repeated.

The above is what was happening on my bed from day one… might it be yours too, but you never noticed… had I not notice how hot my bed was getting one day I would have figured all was well… but when I read the 85c vs. 110c discussion, that’s what triggered this whole effort.

I have no idea if this is software, hardware, or both, but lulz has mine now, we’ll see what they find…

this thread has evolved into a general “something is not heating up” thread.

we have a nifty thermal camera at work, so I took some snapshots just now. Its not an even heat up like I remember it to be when I first got the TAZ working (but I did not take any snapshots of it when it was working correctly…doh)

there is nearly a 30 degree defference in spots, and that would account for the discrepancy we are getting. If the thermocouple is in the cool area, that could be our problem.

what would be very cool to know is if on initial heatup that cold area isn’t cold until after the initial heat up… I know it sounds strange, but I wonder if the mat is such that it could cool with thermodynamics after the first heat up… or after that area cools to s certain temp…

That would account for why my mat acts the way it does… and it will also account for why the bed heats even tho the sensors is cooling…


I let it completelly cool down and then turned the bed back on…it looked identical to the pictures I post earlier. Same patern of heating and not-heating.

My guess is that their is a loose connection in the heater, and one or more of the elements is not turning on. But without knowing how it is wired inside, I am not sure if that is correct.

It does look like the bed heater is messing up.

I flipped the bed upside down to get a better look at the element and took some more thermal pictures.
notice the hot spot near the connector…it might be burning itself out…looks like I need to contact lulzbot directly. I am sure they will handle it.

Ok, that is why it could account for the thermistor seeing it cooling (notice how much colder you are even tho the rest of still heating). From looking at the mat side of mine, it appears that the thermistor was placed approx where you show the cool part of the mat, and the cooling part once the mat starts to heat up…

Thanks, that was very helpful… We’ll see, they should be getting mine today from the PO… it was attempted on Saturday. And that should tell us something…

I just looked at it again, and only 2 traces are heating now…

I am afraid that the resistance may be changing and could damage the RAMBO, so I am disconnecting it for now until lulzbot gets back to me.

Thanks for all the detailed info, we’re looking over it all now.

We just got a nice FLIR today too… research continues…

it is a useful tool, which one did you get?

We got this one:

FLIR Systems E30 160 by 120 Resolution Thermal Imaging IR Camera

It is pretty cool tool so far. We’re getting a much better understanding of what is going on. We have contacted the vendor of the silicon pads too, to get their thoughts.



nice, that is the same model I used.