Errors in Cura status window

Is it normal to see these errors and other messages with each print?
< Error:No Checksum with line number, Last Line: 96
< Error:No Line Number with checksum, Last Line: 96
< Error:No Line Number with checksum, Last Line: 209
< echo:Unknown command: “0”
< echo:Unknown command: “8”
< echo:Active Extruder: 0

Checksum Errors are normal and harmless.
Unknown commands usually the same.
Active Extruder is just letting you know you are using your primary extruder (not a dually)

Thank You!

Hi my taz 5 working great but i did a long print 10 hours as it was finishing the cura 15.1 said not responding nothing on the screen and the print just to the very end the filiment did not bond is there a problem with cura and the taz.

Hello, fleck star
Maybe trying to slow the print down or lower the acceleration speeds.
1.What filament are you using?
2. Do you have an enclosure for your printer?
3. Did your filament strip?
4.Check top and bottom layer thickness.

Fleckstar, This has happened to me a couple times over the past few months. Once with the 14.x and now with the 15.x version of cura. In both cases the printer just stoped printing but nothing was reported by Cura. The LED display just says waiting for user action (or something like that.) Both times, I tried a couple different things to “fix” the problem, but the only thing that got the printer to continue was by using the front panel knob/button and the print job seemed to resume but I had already done enough with cura and the printer that continuing was pointless and I ended up stopping cura control and restated the print job. If it happens again, I’m just going to use the front panel push button to check the printer info/status then return and see if the print job resumes. However, in the latest case, the print head had sat in one place for several minutes resulting in a blob of ABS to pool ruining the print anyway.

In both cases, the 2nd attempt of the print job was successful. I’m guessing something was going on with the PC that temporarily slowed communication with the printer causing it to pause. I don’t recall how long the print job was on the first occurrence but the one that happened just this week was about 2 hours (predicted) and the printer stopped about 30 or 40 minutes into the print job.

Otherwise, I’ve successfully printed some long print jobs (12 to 18 hours) w/o experiencing this problem.

Since both times this has happened to me then completed successfully once restarted, I don’t think it has anything to do with the print settings or filament but more likely a communication problem between the computer and printer or maybe a power line hiccup that put the printer into a weird state. Unfortunately, these kind of random events are very difficult to debug.

I am trying to debug the same problem (random pause waiting for user input). For me it happens on long print jobs (10+ hours) and it usually happens on the first layer. I suspect it is a communications problem as the same gcode prints reliably from a SD card. I’m not sure why it would be slowing as it is a fairly powerful PC running cura and it’s not doing anything else. Anyway, I am trying with an Ubuntu machine to see if that stops the problem.

For my shop or printing laptop I have ALL power saving features turned off, I do use the blank screen as screen saver. I also disable Windows Update and Flash and whatever else you have on it that needs to update. If you keep Facebook and Twitter accounts active on this computer your asking for trouble. My shop computer is a Lenovo W500 with 8 Gb Ram, Windows 7 Pro 64 I have printed 13 hour jobs so far without a problem, off the USB Port.

The machine is an i5 with 8Gb of ram. It has happened with both Windows 7 and Windows 10. All power saving is disabled and nothing else is running. It was running Cura 15, but I have upgraded to Cura 17. It’s too early to see if that made a difference. Oddly enough it doesn’t seem to happen under Ubuntu, only on Windows. It doesn’t seem to happen with the Mini either, but the jobs there are shorter.

Is your machine on a Wireless internet or network? Try disabling it while your printing.

FYI if the machine is working fine, but failing on the USB print function, don’t change any of your setup or printing settings, or change filament or whatever… its related to the time issue and something like you already noted communication.

Just for another data point - I’ve successfully run overnight print jobs concurrent with a full backup of my system that usually takes a couple hours to complete. This has led me to believe that my problem print jobs (2 of them) may have been induced by an electrical glitch (e.g. power spike) that caused data between the CPU and the printer to get scrambled causing the printer to get confused resulting in the “waiting for user input” message.

IMHO There’s just not that much data that needs to be sent across the USB interface so I’m hard pressed to believe it’s a problem with throughput of either the CPU, memory, or the USB bus.

Plugging the printer into a UPS to guard against spikes might help but in my case, I’m not sure that the UPS can handle the additional load of the hot end and heated bed.

I am guessing your just downloading the g-code to the controller a little at a time and the computer has not a lot to do otherwise. You have already proved its not the TAZ or the code by printing off the SD card. Check and see if turning off the wireless makes any difference. I have noticed Cura tends to kind of freeze up when a long print has completed.

Hello All,

I’d like to chime in on this subject since I just read some comments touching on the USB interface & I may have important information based on my own observations & adjustments to my system

1st, I’m new myself & only had the TAZ-5 for 1 month but, I’m an engineer in the semiconductor industry & so I work on & calibrate high-end motion systems occasionally & thus felt comfortable & have really enjoyed setting up, calibrating, & testing my rig.

I started out trying a USB-to-Ethernet adapter (both wired & wireless before you ask - tested both) & what I found was it was easy to remote control manual movements in getting ready for a print job but, while running a print job the interface could Not keep up with the printer (@ 100% or normal speed, settings, etc - ABS btw) - it would “micro-pause” or hiccup & caused bad resolution results - my resolution for now & has been to prep my file & save it to the SD disk & then run the printer from local interface - I have been successfully running full envelope size print jobs that run over several days w/no issues by printing from SD on local interface - so at least this way works as a comparison :smiley:

Hi, I would like to mention I have the same error also.
Did 20 hour plus prints but when the printer has to do a lot of moves and not a lot of layers (greebles on a starwars model in my case) it seems the printer just goes into a sleep or waiting for user state. Only thing to help the waiting for user issue is to touch the knob on the display. doesnt matter what you do, as long as it has moved the printer continues. The sleep I have not been able to find any cure for it so far.
Please let me know what to do!

To share another data point.
I have also had my TAZ 5 mysteriously stop a couple times in the past but nothing recently (several months ago.)
I am currently running Cura v17.x.

I have never had a problem with the computer unable to send sufficient data to the printer over the USB buss to keep it printing. I regularly multi task while printing and doing other stuff without any issues. While printing I typically surf the web, run my 3d cad program, run excel, or check my email using MS Outlook. I’m not running some super gaming computer; just an i5 with 6gb of memory.

I have had USB problems with other computers, especially for some reason lap tops, but this has always been a general failure issues such as the USB buss won’t initialize or Windows reports an error with the HW in the event manager, etc. and in these cases, nothing works reliably with the USB.

I believe the amount of data that gets sent to the printer is miniscule compared to other stuff you might typically use the USB for such as connecting to a display, reading/writing to an external HD, or burning a DVD.

So, IMHO, I really doubt you are having an issue with the USB buss unless you’ve noticed other USB HW that is also failing to work.

It may be that Cura stops sending data to the printer because of some kind of communication breakdown but this is likely to have more to do with how Cura and the printer are performing their hand-shaking or errors in the data built by the Cura code rather than a problem with your USB buss.

You might try to slice your project with something else (e.g. slic3r) to create the gcode and/or use a different printer control program to print the same item.

Just my 2 cents,

I have been able to reproduce the error 100% in a specific file and always in the first 5 or 6 layers so easy to test with.
Willing to share to go through the gcode if needed!

Yes, go ahead and upload the gcode.
How was the gcode created?
Can you upload the STL file too so I can create new gcode via Cura and slic3r for you to test with?
I’ll also compare it to the gcode you post too.

Please share ASPHIAX! Having the gcode, stl, printer, firmware version, and version of Cura that you are using would be tremendously helpful.

To resurrect this - not sure if anyone else has found the answer, but I’m getting it as well, on a specific file.

Beginner with TAZ5, I’ve gone through a lot of similarly large (but not quite as large) prints already, with no problems.
This file (printed at 2X default size (it’s the collar from a dalek from here : )), with a raft and scaffolding, always stops at the same point - third layer of the raft, dead-centre at the edge.

I’ve tried with a raft, with a brim and with neither… same thing each time.

Now… here’s the funny thing… the machine sounds different. When it’s printing this one, it sounds graunchy, like it needs some more oil somewhere. Go back to a previous print that works fine, with exactly the same Cura settings, and the sound is back to how it should be. No - I know it’s not scientific, but…

Cura 18.03
Taz5, firmware Marlin 2015Q2

Any ideas??


shoulder.stl (5.27 MB)

I’m going to download the file and generate some gcode and print the first few layers.
I’m assuming you are using the quickprint settings … What values are you using for ease of use, material, profile, etc.