FlexyDually - Print Only Flexible

Hey all!

Just got my FlexyDually set up on my Taz 5, and it’s been incredibly cool. Part of the reason I got it was to be able to print each material individually without having to exchange extruders, reflashing firmware, etc.

Its straightforward to use the rigid extruder by just not merging multiple STLs for dual extrusion, but I can’t find a good way to only print flexible. I’d like to set this in software in Cura, and not have to unplug and switch extruder cables. Is there an official way to do this? Changing a specific bit of gCode? If anyone knows how to do this I would GREATLY appreciate your input, thanks!

Also a mid-print pic just for fun:

I’d like to know if there’s an easier way too. Currently I just create like a 1mm cube off to the side and use that for the ABS portion of the print. Works fine.

T0 - Use back extruder.
T1 - Use front extruder.

You put one of these selections up at the top of the gcode to tell the printer to use that extruder.

You need to use a single extruder profile to use only the one extruder. This allows you to use just one hot-end, and not have to re-flash your dual extruder firmware. Using the single extruder profile allows you to specify hard/flexible filament/heat/speed settings to be used for that model.

Ok rad, thank you! I was worried that that method might use the ABS print settings and just port them over to the second extruder, but I gave it a whirl and it’s printing like a dream. I got a weird artifact in Cura when looking at the layers, visualizing past layers as ABS:


But I just made sure that the floating part was still over the bed and it’s working perfectly. Thank you!!

Oh, ok so the print I just ran is probably using ABS settings then. I imported the NinjaFlex profile, and switched the extruder to T1 in the gCode, but I’m still getting that weird top layer offset in the layer visualization. Is that just an unavoidable thing? It’s not really doing anything bad except taking away 50mm of my Y axis.

Did you check your model to make sure it does not have errors in it by running it thru a model check like Netfabb basic or Netfabb’s online check program? You should not see any odd layers like that on a model.

Don’t we have to change anything in the start/end gcode?