Help with Slic3r

I’m having an issue with slicer only applying a single layer to non horizontal or vertical planes. Anywhere that I have a surface that isn’t at 90 or 0 degrees, slicer is only making one pass over it. I have both the perimeter and top/bottom set to 4.

Here is an example from slic3r


This is what Cura produces, nice full surface layers regardless of where they are at.

Is there a setting in Slic3r I’m missing that makes it do this?

I think you swapped your images?
Check if you have enabled “Extra perimeters if needed” in Layers and perimeters.

It looks like your gaps are showing through on angles. Increasing vertical shells should help make those thicker, and less transparent.

Yes, images got swapped. Sorry about that. White is slic3r, black is cura.

Extra perimeters if needed is checked. Should that be unchecked?

Vertical shells-perimeters was set to 3. Increasing this should help?

Check is good. That’s strange, I know Slic3r has a problem with this feature, but I got this only at very low layer heights. Which Slic3r version are you running, whats your layer height?
You could work around this with a hughe amount of top layers (check the 3D preview if it’s OK), but thats not how it should be.

Layer height is .2mm. I’m running 1.2.9.

What setting do you have for number of solid top layers?

3 on that print. I’m running anther print very similar to that one with a 4 top/bottom/perimeter. I’ll post the results once it finishes.

4 layers seems to have done the trick. Thanks for the help guys!