Slic3r Ignores some settings?

Hello All,
I have noticed on a couple of my prints that Slic3r will ignore the slice settings. In the most recent slice the setting for solid infill, perimeters, and infill all have the same speed of 140mm/s. However, when it starts the 20% infill and the perimeters on these layers is visibly slows down. It also should be printing infill every 2 layers during this time, yet it prints every layer.

I have seen this before on other setting on other prints. Does anyone know what cause this?

I am using Slic3r 1.0.0RC3
Windows based computer.
FreeCadHalfInchCube-Fast-TAZ.gcode (146 KB)
FreeCadHalfInchCube.stl (684 Bytes)

The slowing down could be the cooling feature or perhaps the firmware acceleration limits. The infill every 2 layers I’m not sure about.

What version of slic3r are you using? If you post your .stl and .gcode, it will be easier for us to help.

I’ve attached the stl and gcode to the top post. I’ve also added that i’m using slic3r 1.0.0Rc3 in the first post.
So what i’ve noticed is that for options like number of layers, if i enter a number in the field it doesn’t always update take. for example i changed the number of top layers from “4” to “2” by clicking in the field and typing “2”. but when i sliced it and looked at the code it was still set to “4”. Only after i click in the field and hit “TAB” does it update on slicing.

as far as my infill every 2 layers issue, will slic3r print layer heights thicker than the nozzle diameter? IF my layer heights are set to 0.25mm and my nozzle diameter is 0.35, does slic3r read that and say “nope, i’m gonna print an infill every layer cause i don’t want to to print layer heights of .5mm with a .35mm nozzle”?

Are you doing the slicing directly from Slic3r or having Slic3r run through Pronterface or Repetier?

I’ve had mixed success with using the “Infill every N layers” setting, with both a 0.35mm and 0.5mm nozzle, on .10b and RC1. Slic3r will allow an extrusion larger than the nozzle diameter, as the extrusion will swell once extruded. Slic3r usually starts complaining when using “Infill every N layers” is set to 3, but that’s a bit excessive. Have you tried our latest Slic3r profiles here: ?

I’m slicing directly from slicer.
I haven’t tried the newest profiles but i will now.