TAZ 6 Z Homing Crash

I’ve recently tried to print some parts on our TAZ 6 printer, and the Z homing is not working properly in the starting script. I’m slicing with Simplify3D, but I’ve also tried Cura for Lulzbot and had the same issue. I’m using the standard startup script, and the issue is with G28 Z. The first G28 homes X and Y successfully, then it executes G1 X-19 Y258 F1000 ; move to safe homing position, and ends up right over the homing switch. After the nozzle warms up it executes G28 Z, which should just move the Z axis down until the nozzle hits the homing switch, but instead, for some reason, it also includes the X and Y axis in the homing sequence again. This moves the nozzle back over the rear bed corner before lowering the Z axis, and crashes it into the bed unless I power off the machine first. I’m not sure why it’s doing this, and I’ve checked over the G code on the SD card to make sure there wasn’t an extra line of code or anything else that would cause this movement. Has anyone else had this issue and have you found a way to solve it?

Have you recently updated your Cura version perchance? If you did, did you also make sure to clear your computers cache and flash your firmware through the new version of Cura? If you updated Cura and either of these steps was missed it could explain the issue you are having.

In case this applies to you here are some links to how to clear your cache based on OS:
Ubuntu: https://www.lulzbot.com/learn/tutorials/cura-lulzbot-edition-installation-ubuntu

Debian: https://www.lulzbot.com/learn/tutorials/cura-lulzbot-edition-installation-debian

macOS: https://www.lulzbot.com/learn/tutorials/cura-lulzbot-edition-installation-macos

Windows: https://www.lulzbot.com/learn/tutorials/cura-lulzbot-edition-installation-windows

And here is a link for flashing your firmware using the new software:

I’m having this same issue with my Lulzbot Taz 5.

G28 Z does not home only the Z axis, it is homing all three!!! :neutral_face:

Clearing cache and upgrading Marlin firmware didn’t make a difference.

Also I’m having a new problem I’m printing with the Flexydualy V2 head, but the cooling fan isn’t turning on… I also have the Dual head, and the fan on the is turning on instead! (I had to keep one of the dual heads installed because I was getting an OUT OF TEMPERATURE warning.)

there seems to be some kind of mixup with newer flavors of Marlin.

I ended up opening up Lulzbot Cura 21.08, (AKA Cura 2?) and re-flashed the firmware on the Lulzbot with the original Marlin Firmware V