Just bought a used Lulzbot Mini 1 and having issues connecting to it

I’ve used Prusa 3D printers at a local hacker space and in December I as able to score a used Lulzbot Mini 1 and I’m having difficulty connecting it using Cura LulzBot Edition v4.13.4. My laptop is running Ubuntu 20.04LTS amd64 (fully up-to-date) and I see in /var/log/syslog that when I connect the USB cable to the Mini it is recognizing a new USB device has been connected:

kernel: [11069.086875] usb 5-2: USB disconnect, device number 3
kernel: [11073.821382] usb 7-2: new full-speed USB device number 8 using xhci_hcd
kernel: [11074.024353] usb 7-2: New USB device found, idVendor=27b1, idProduct=0001, bcdDevice= 0.01
kernel: [11074.024359] usb 7-2: New USB device strings: Mfr=1, Product=2, SerialNumber=220
kernel: [11074.024362] usb 7-2: Product: RAMBo
kernel: [11074.024365] usb 7-2: Manufacturer: UltiMachine (ultimachine.com)
kernel: [11074.024367] usb 7-2: SerialNumber: 74035323434351A081C1
kernel: [11074.034323] cdc_acm 7-2:1.0: ttyACM0: USB ACM device

After that it reports the following is logged to syslog and Cura can’t see the printer:

“ModemManager[1135]: [base-manager] couldn’t check support for device ‘/sys/devices/pci0000:00/0000:00:10.1/usb7/7-1’: not supported by any plugin”

I tried all 4 of the USB ports (2 x USB3.0, 2 x USB2.0) on the laptop and they all got the same message. Anyone have any recommendations?

UPDATE: I tried using Windows 11 and it was able to recognize my 3D printer and I was successfully able to do my first 3D print of Rocktopus with my Lulzbot Mini 1. I’m still not sure why my Debian and Ubuntu laptops both didn’t work :thinking:.