Lulzbot Cura 3.6.25 Does not work for TAZ PRO and M175

I have a lulzbot Taz Pro with a M175 toolhead and octograb bed. It never had any major issue until I updated Cura today. Before, I had used the 3.6.23 version, which worked flawlessly. Once I did the update, the printer cannot seem to align the toolhead anywhere. When it was tasked to clean the nozzle, it missed the brush a few millimeters to the left and was above the build plate. Worse, during bed leveling, the nozzle would miss the metal bed corners and the heat block would hit the first two. On the third corner, it would miss completely and hit the bed plate, scraping my octograb surface. I switched back to 3.6.23 and the issue is gone.

We did end up changing the start gcode in 3.6.25 , Did you also happen to flash the new firmware that is in 3.6.25? Here is the commit which changed the start gcode,

I believe that I have found where the issue was, I have tested it on a factory TAZ Pro in my office with the M175 tool head and have it functioning properly. Download the bin file labeled as Marlin_TAZPro_Universal_2.0.6.5TEST_a938b197 from here, and in Cura Lulzbot where you automatically update firmware, there is an option to upload custom firmware. Click that option and select the .bin file that you downloaded.

Make sure to select the M175 from the ToolHeads menu on the TAZ Pro screen.

Let me know if this fixed your issue.

I tried the Marlin_TAZPro_Universal_2.0.6.5TEST_a938b197 custom firmware. It worked when not printing, but every time I tried to print with it I got a homing error. I made sure that the correct toolhead was selected and that the firmware was properly installed. Until the problem is fixed, Ill use the 3.6.23 version of Cura.

@penn1793 Can you share more information on when the homing error came through?

I have not seen this issue on the universal firmware yet, but the dual extruder has a bug of while probing the Z motors will turn off unexpectedly and fail to home. Does this sound similar to your issue?