Lulzbot Taz 6 - Aerostruder Homing Issue

Hello Everyone,

I have been using Lulzbot printers for a while now, and mostly could figure out issues on my own, but this time i’m stuck.

I was using my Lulzbot printer with a Aerostruder no problem, until the day that i had a catastrophic failure and had to switch to a Flexydually as a backup extruder until i got parts to fix my Aerostruder.

Fixed the Aerostruder but now my printer refuses proper home, we all know that lulzbot taz 6 should home x and y and them home a little bit to home z using the z-button, right, mine is not doing that… I have quadruple checked firmwares, tried all different versions of marlin that i could get my hands on aka:

If I return the firmware and the Flexydually everything works :confused:

Video of the weird homing:

Video of if properly homing after flashing flexidually:

I’m truly lost, if someone has any idea let me know!

Just one FYI: I’m a software developer, even compiled my own versions of marlin back on the day of getting taz 5 and capacitive sensors to level the printer bed.

Have you tried flashing anything from the newest version of LB Cura or are you only flashing files from the download site? I have flashed several Taz 6 with the standard Cura firmware without issue. I am wondering if they have incorrect firmware loaded on the download site.

I assume you did select the aerostruder print head and didn’t leave it on the flexy dually?

I have tried using the LB Cura, and manual download HEX file, i also thought about the incorrect firmware but that theory got dismissed as I downloaded really old firmware for the aerostruder and the issue persisted.

Yes, if you see the video, you can check the the firmware loaded shows aerostruder.

I feel like an idiot, but I’m posting anyway so if anyone has the same issue they will know how to fix it.

I had my switch on the x axis on the extruder wired incorrectly, so the printer was thinking it was hitting the limit switch always.



Glad you figured it out.