Taz6 Flezystruder problem with "Auto Home"

I recently got a Taz6, and am having issues homing all axes with the Flexystruder attached. With the stock extruder attached, I was able to perform one of the test prints that came preloaded, and on the LCD menu selecting “Movements” --> “Auto Home”, the homing sequence goes through the steps of touching off on the manual switches, first on the X-axis, then Y-axis, then Z-axis. During the sequence, after the Y-axis touch-off occurs, it shifts the Bed towards the back slightly so the nozzle is hovering over the Z-axis manual switch (round button), which should be the appropriate home position for X/Y before the Z-axis touches off.

I also bought a Taz compatible Flexystruder, and after installation, which is as simple as tightening one fastener and plugging the connector in, I attempted to perform the same “Auto Home” feature. This time, it touches off X, touches off Y, but it doesn’t shift the bed back at all before homing Z, so the nozzle isn’t hovering over the manual Z switch when attempting to touch off. I can’t find anything relating to Home Position in any of the settings on the LCD menu. Does anyone know how to fix this problem?

Install firmware for the TAZ 6 with V2 flexy via Cura
Add Machine> flash the firmware when prompted.

I have mine flashed and still had problems with the automatic bed leveling. I posted here https://forum.lulzbot.com/t/taz-6-flexystruder-wipe-failure/3521/1

So glad I found this thread! I am having a very similar problem. Even the steps I followed were the same.

I even switched everything back to default (extruder head, firmware, filament) and still have the “Home” sequence problem. I actually have been turning the machine off before it pushes too far down the Z axis and damages the bed. Then I have to manually move it up. See attached pics.

It seems that installing the Flexystruder and flashing the firmware has thrown off its “center”. And after trying to go back to factory settings still hasn’t worked.

Any help is greatly appreciated.

This seems to have fixed it. Sorry I am a noob to 3D printing. Didn’t realize there was a calibration file on the SD card!


I’m still having this problem. During startup sequence it homes x and y then positions z above zmin button. Once extruder reaches cleaning temp z axis raises 10mm and y axis homes. Then z goes down and crashes into bed.