Makergeeks PLA filament?

Hi, we decided to get a spool of Makergeeks PLA fillament 3mm, for our Lulzbot Mini, since it was pretty cheap and on a special.

After testing it with several temperatures we found it is always getting stuck inside the head of the printer, contacted Makergeeks and they told us they are using it at 230c on a TAZ5, but it doesn’t work at that temp on our Mini.

I was wondering if anybody has experience with this fillament, or if there is a big difference on how the TAZ5 handles the fillament compared to the Mini, maybe the fillament we got is just bad?

Well I guess if nothing else works, I will know better next time, it was too cheap to be good, and their return policy only gives me store credit which sucks, since I don’t want to take another chance.


I run Ultimachine and eSun PLA in my Taz5 and Mini at the same temp without issue. Ultimachine at 210, eSun at 205. The Ultimachine likes 223 - 225 in my Taz2 equipped with a E3D V6.

Yes I have also used Makergeeks PLA for a TAZ 5 and had trouble with it clogging. I think what is happening is there is creep and if you print at a high speed you’ll have more successful prints.

Have had good results with LulzBot and Ultimachine filament. SeeMeCNC filament should also be good. Inland (Microcenter) brand 1.75mm filament is an acceptable source of cheap 1.75mm filament, but not great.

For a simple plastic product, there is a surprising degree of variablility between brands.

Anyone want a sample of Velleman PLA filament to try? :smiling_imp:

I also recently purchased this filament, Makergeeks natural PLA (supposed to be FDA food safe). After ~10 iterations using different print settings and hot end temperatures, I get slipping/notching every time, which leads to a bird’s nest of a print. I’ve gone as high as 240C (the temperature recommended to me by Makergeeks tech support) and as low as 220C; all with the same results. I’ve also noticed that just manually feeding the filament in, I can feel huge variations in flow resistance; I manually fed in about 3" at a constant temperature, and at times it would pour out, and then it would slow to a crawl. Assuming this is happening during prints also, its easy to see how the notching could occur. Not sure if this is entirely due to the filament, but when I switch back to HIPS, I get great prints.

So glad I’m not the crazy one (for a change). I purchased 2 spools through Makergeek’s grab bag. I got “Natural”, which I’m pretty stoked about, but I can’t get a successful print for the life of me. I think my wife has had enough too (though I haven’t seen her in three days BECAUSE I’VE BEEN IN FRONT OF THE PRINTER THE WHOLE TIME :slight_smile:

I’ve printed 7 hour prints with Lulzbot’s PLA just fine, so I know my setup is good.

I ordered a 40mm 5v fan and have printed a shroud (in ABS, of course), so I’ll leave the printer alone and wait for the fan to show up. We’ll see if that fixes the issue.

I also got two rolls ofr PETG, but won’t touch those until I get my PLA worked out.

So, I spent the weekend banging my head against the wall with the Grab Bag filament I got from Makergeeks with no luck. It seems that with both the PLA and the PETG I can not, for the life of me, get a full print out of this stuff. Seems that no matter how hard I crank down on the idler, I can’t get a full print (and yes, tried to back off, but that was clearly not the answer).

Both materials suffer the same issue; I get some random % through a 40mm cube, and the filament starts to grind, and I end up with cute little hairy partial cubes. I’ve played with temp., I’ve played with Z-offset, I’ve played with tension. Nothing seems to solve the issue.

NONE of the spools were sealed in air tight plastic, and although PETG doesn’t absorb moisture, I think this might be part of the issue. (However, I do not get bubbles or popping, so, who knows. I’m out of ideas.

And just so you know, I BROKE my idler arm in the process! So super glued it back together, grabbed the idler model from Lulzbot, switched to some ABS I had laying around, and printed a replacement. One shot, perfect print.

Monday is a phone call to Makergeeks to see if they will work with me to resolve this. I think the material has some global defect. Just can’t figure out what it is.

And yes, I have printed dozens of PLA, ABS, and PETG parts with eSun.

It sounds like you are going though the same difficulties we were. We actually broke an idler too.
You are very likely experiencing what has been called “heat creep” in PLA.

It can help a bit to reduce the retraction distance, frequency, etc. We discovered that the filament would grind/jam during the retraction, or immediately after a retraction. Also helps to reduce the percentage of post print cooling.

However, what the real problem with printing PLA turns out to be is the heat sink fan. I built a new duct and replaced the little blower with a 25mm fan, and all my PLA problems vanished.

Here is a link to the duct, the 25mm fan, and how to replace it:

You can replace the little fan with a 30mm fan and duct like they use on the Taz6 it you prefer, but I’m attached to my persona solution. :wink:

Bill D.

Here is the Lulzbot link to the Taz6 30mm fan heatsink duct:

I haven’t done much of anything with PLA, so I can’t comment on that. However, I find the MakerGeeks PETG to print about the same as eSun. I’ve had both grind out, but tightening the idler a bit (I’ve already printed a spare) and increasing the extruder temp took care of it. Some models/slicers generate a lot of retractions. If your slicer supports it, try having it display retractions on the preview. Adjusting the settings on the slicer with an aim to limit the total number of retractions, and perhaps use slower or shorter retraction length, can make a big difference. Maybe even test with retraction disabled to see if it helps at all.

I’m going from memory, but for print settings I run 255C extruder, 75mm/sec max speed, 50% reduction for outside perimeters and solid infill, 40% for first layer. Retraction is 3mm@30mm/sec. I found I had the most stripping on sparse infill layers, when it’s trying to go quite fast. Kicking up the temp helped a lot there. Higher layers also need increased temps for the same reason. I had great prints at 0.1mm that failed at 0.2mm until I increased 5-10C.

Mine did come sealed in plastic with desiccant. It shouldn’t matter really with PETG, but PLA will need it. I have heard of people getting it without the plastic though. I’ve ordered 5 spools in 3 orders, never had an unwrapped one. I don’t think mine were vacuum sealed, at least not as tightly as some other rolls I’ve received, but I haven’t had any moisture problems with the PETG or ABS I’ve used from them.

All that said, yours might indeed be defective. Or maybe it all is and I’m managing to work around it and/or just dumb luck. I hope you get it figured out or the vendor takes care of you. I’m interested to hear what they do as it’s always nice to know how vendors behave when there are issues.

I was also having a lot of problems with Makergeeks PLA filament grinding on parts with lots of retraction. So, I gave your mod a try but still have the same problems. My first print failed about halfway through (it is a tough one with a lot of retractions, I have never completed it with PLA).

Should I try messing with my settings? I am printing a pretty standard PLA profile: 200C, normal retraction settings, recommended idler tension. I have tried changing all sorts of settings before to get this print to work and have failed every time.

I am not for sure saying it’s the Makergeeks filament causing the problem, but I’ll try out some eSun with the same settings and report back.

Lulzbot seems to have similar problems, maybe it is the filament:

“Lulzbot seems to have similar problems, maybe it is the filament: … ting_Dcos/”

Oh, very interesting find. Thanks. I feel a little better. What kills me is that I printed the new cooling shroud and got the 40mm fan, installed, no help with this or their PETG.

So I used the EXACT same gcode, but with eSun filament instead of Makergeeks. The print came out perfect first try!

I really do think Makergeeks filament does not cooperate well with Lulzbot printers (probably others too). Maybe it needs drastically different print settings than other PLA? However, I have tried a lot of permutations with no luck, so I don’t really think so. Makergeeks PLA has worked perfectly fine for me with prints that have little retraction, so it’s not totally useless I guess.

I feel kind of ripped off with this filament. I didn’t realize how much variation there was between brands.

I will agree that whatever formulation makergeeks is using, it is not at all compatible with the existing profiles, nor does it seem to be remotely close. Between their PETG, which they claim is the same formulation as t-glaze, literally the same supplier as taulman, and their PLA, the only conclusion I can come to is either the batch they were selling in their random blowout for $33 a pair is bad inventory, or, I don’t know what else. When I talk to their support, they insist they are using a Taz 5 with the standard Cura configs for both of these materials, and getting good results.

Sigh. I have two spools of each of the PLA and PETG from that sale, and at this point, I feel like I just have four spools of useless material that I spent $66 on. :frowning:

I think it’s their overall formula which isn’t working well for us, not some recent batch. The filament I am having trouble on was bought 6 months ago. :frowning:

They are still very usable for prints without a lot of retraction for me though, so the filament is not completely useless I guess.

Still trying to get it to print, but in an effort to go to extremes, I tried 100mm/s with no restrictions. I compared this to an all too familiar 60mm/s fail. Even though it’s not the “right” solution, I kinda dig the results :slight_smile:

Ok, after quite a number of failed prints based on 100 various tweaks, I ran into the discussion on adding a small pre-treatment hack. Adding a bit of monorail oil to the filament as it feeds.

Well, I found a sponge, cut off a 1x.5 inch piece, put a few drops of mineral oil on it, wrapped it around the filament, and went to town. The previous post shows small scale results at various speeds.

Last night, I pulled the trigger on a print that would normally fail anywhere from 6 layers to 2 inches given my current setup.

Oh, and by the way, except for temp, this is basically a stock PLA config. Printed with a 2mm wall at full scale. 7:00 hour print. 60mm/s

Oil bushing here:

I think I found a solution for Cura users at least.

I had been having the same issues described above. I would get less than 50% through print on different objects, and it would clog, gum, and basically cease to extrude. I did a cold pull and at the end of the the filament was showing a sheathing of sorts?? The center was hollow, and all that was left was a clear outer plastic sheathing. Weird… On top of that the filament was binding and being stripped by the feeder gear.

I made a few changes, and am now print successfully with Maker Geeks PLA 2.85 Filament.

Adjust nozzle size to .5 instead of the preset (I’m assuming that with the preset nozzle size of 3.something, it’s not allowing the full width of the filament to pass.
Retraction speed set to 17
Minimum travel set to 0.5
Minimal extrusion set to 0.01
Z Hop set to .075
Filament diameter set to 2.9
Hot end set at 210
Bed set to 60

I’m assuming the largest difference is the Nozzle size adjustment. I’m going to go through and adjust a little more, maybe drop the nozzle size down a bit and see if that helps to clean it up, as I do feel it’s over extruding a bit. However, the issue of the of the clogged nozzle is now resolved, and I’m getting a consistant print, the quality seems pretty good. The only other thing I think I’d like to adjust is to drop the fill down a bit, I think because the nozzle is larger, the 20% fill is pretty heavily spaced out, I’d recommed 10-12% on future prints.

Also, as a note, I’ve not made any modifications to my machine in regards to fans, etc. Hope this helps. I’d be curious to know if anyone else has the same results with the above adjustments.

Thanks for the post, I’ll try your settings out. What machine are you printing on? What is its actual nozzle diameter?

TAZ 5, the nozzle is the standard .5 that comes with it. Cura has the setting marked as a .35 or something? I’m not sure as to why.

But I think the issue is 2 fold, and it’s just a matter of finding the right combination. I may be wrong, but I’m thinking the outer layer of the filament is burning, either due to temp or getting hung up because of the nozzle output size, or other factors. It may be sticking to the inside of the nozzle and then creating the issue of not retracting, and in turn causing the feeder gear to chew away at the filament. The first print looks great, but I was still running at a high temp of 210. The following print, I started getting the same issue again. I cold pulled and saw the same hollow tube, no black in the center. I’ve started another print at 195, all the same settings, and it seems like there is better control, less stringing, and so far hasn’t bound up. After this print, I’ll cold pull again and see if the filament has improved on the inside.

As a side note, I’ve noticed the filament seems to be wound very tight, I’m wondering if that’s also preventing the filament from moving through smoothly, and hanging up (i.e. burning)…