Mini Gen1 Update Cura & Firmware - Won't work

Last January I decided to try to update Cura from 21.08 with the original 1.0.2.2 firmware to Cura 3.2.32. Found I also had to update the firmware to 1.1.9.16. I kept E steps and Z offset to the same values. When trying to do a print I received the following console message, "Error: MINI Temp triggered, system stopped Heater ID: bed Error: Printer Halted. kill()called!

So I went back to the old versions and all okay. Been using the old versions since. Today I tried to update to Cura to 3.6.21. Had to up date firmware to 1.1.9.34. ran a print and received the same console message. Went back to older versions and all okay.

Wonder why I can not up date Cura?

FYI. When I install the latest version of Cura I update the firmware via the automatic update, not custom update. I assume this is correct.

Is this how others update their firmware?
Can anyone think of what I might be doing wrong?

That is the procedure I use. There were multiple flavors of the original Mini so make sure you have selected the correct one. I’d call LulzBot support and if they answer, they should be able to help.

Update: My drive C: is a solid state drive and they are not that large. It is great for Windows because on cold boot it is FAST. So I have been putting all my apps on drive D: as it is a very large drive. So I though, maybe CURA needs to be on drive C: as I was finding some cura-lulzbot folders and 3.6 folders on both drives. I uninstalled and cleaned up any leftover folders. I reinstalled Cura 3.6.21 on drive C: I then updated the firmware again and set the proper Z offsets and E steps. It had a .stl file loaded, octopus. So I selected a PLA and printed it. It worked. Thought my problems were solved but loading another .stl file to print I was back to the same old problem. Got the console Error:Printer halted. kill() called! For some reason I decided to reload the firmware again and the Z offset and E steps. Second time was a charm. It now works. I am on my third print. Hope this keeps working!!!

One thing I noticed is when probing the bed corners it sometimes forces the bed to move downward. I am not so sure I like that. Nozzle looked clean when it did it.

After printing a 12 hour print successfully it quit working again. Put the old firmware in and used the older Cura and had the problem appeared after doing many prints. After much troubleshooting (using the Error: MINI Temp triggered, system stopped Heater ID: bed Error: Printer Halted. kill()called! as a where to look) I found the problem. Very Very Intermittent bed temperature wire. It would open up for a very short period of time… I am guessing the older firmware didn’t check the temperature as often since it was working and new SW wasn’t working. After replacing the wire and running many more prints with latest CURA and firmware all is okay.