My LuLzbot Taz 6 loses connection to PC. How can I resume the print?

This cause the nozzle to stop on the print because it not getting the next step on what to do from the PC. I have seen many video and they all take the same step by cleaning and re-homing the nozzle.

Here is where things start to differ, they are able to access their G-code through the slicer program and tell the print to start from a height (which is at the top of the object) and are able to click print from there.

My issues is I can not find this G-code with the slicer program the Taz6 uses.

Any help on resume a print after a PC disconnect would be helpful.

Most slicers put comments in the G-Code file indicating the layer number. E.g. for Cura, the comment looks like this:

;LAYER:5

The number indicates the layer. Anything following a semi-colon in a g-code file is a comment (not real code). Cura (and most slicers) embed comments to indicate each new layer.

You can open the g-code file with a text editor (make sure it’s a text editor that wont put special characters in the file) and edit out the lines between layer 0 and the layer you need.

IMPORTANT: Some of the g-code near the start of the file is the printers “Start” g-code. This is the stuff that starts pre-heating the bed, wiping the nozzles, doing the bed-level process, etc. With a partially build part on the build plate you probably have to skip that because the X axis gantry will probably hit your part. This means you’ll likely need to delete even your start g-code and just manually set the temperatures and prime the nozzle.

Thank you, but in Lulzbot Cura edition I can not find the location to access this G-code. Is it accessible through the program or do I have to do some file digging?

After slicing, instead of “Print via USB” (or whatever the actual text is), choose Save file. That will save the file as gcode and then you can open/edit it.

Thank you all for the help. I will see if I change the right stuff to resume this stopped print.

G-code details
Make sure the g-code is suitable for your printer and printer configuration before sending the file to it. The g-code representation may not be accurate

This is the error I am getting now and this is the G-code after the change.

;Generated by Cura LulzBot Edition GCodeWriter Version: 3.6.20
;FLAVOR:Marlin
;TIME:97719
;Filament used: 79.9729m
;Layer height: 0.25
;Generated with Cura_SteamEngine 3.6.20
M82 ;absolute extrusion mode
;This G-Code has been generated specifically for the LulzBot TAZ 6 with standard extruder
M73 P0 ; clear GLCD progress bar
M75 ; start GLCD timer
G26 ; clear potential ‘probe fail’ condition
M107 ; disable fans
M420 S0 ; disable previous leveling matrix
G90 ; absolute positioning
M82 ; set extruder to absolute mode
G92 E0 ; set extruder position to 0
M140 S60.0 ; start bed heating up
M109 R140 ; soften filament before homing Z
G28 ; Home all axis
G1 E-30 F100 ; retract filament
M109 R140 ; wait for extruder to reach wiping temp
G1 X-15 Y100 F3000 ; move above wiper pad
G1 Z1 ; push nozzle into wiper
G1 X-17 Y95 F1000 ; slow wipe
G1 X-17 Y90 F1000 ; slow wipe
G1 X-17 Y85 F1000 ; slow wipe
G1 X-15 Y90 F1000 ; slow wipe
G1 X-17 Y80 F1000 ; slow wipe
G1 X-15 Y95 F1000 ; slow wipe
G1 X-17 Y75 F2000 ; fast wipe
G1 X-15 Y65 F2000 ; fast wipe
G1 X-17 Y70 F2000 ; fast wipe
G1 X-15 Y60 F2000 ; fast wipe
G1 X-17 Y55 F2000 ; fast wipe
G1 X-15 Y50 F2000 ; fast wipe
G1 X-17 Y40 F2000 ; fast wipe
G1 X-15 Y45 F2000 ; fast wipe
G1 X-17 Y35 F2000 ; fast wipe
G1 X-15 Y40 F2000 ; fast wipe
G1 X-17 Y70 F2000 ; fast wipe
G1 X-15 Y30 Z2 F2000 ; fast wipe
G1 X-17 Y35 F2000 ; fast wipe
G1 X-15 Y25 F2000 ; fast wipe
G1 X-17 Y30 F2000 ; fast wipe
G1 X-15 Y25 Z1.5 F1000 ; slow wipe
G1 X-17 Y23 F1000 ; slow wipe
G1 Z10 ; raise extruder
M109 R140 ; wait for extruder to reach probe temp
G1 X-9 Y-9 ; move above first probe point
M204 S100 ; set probing acceleration
G29 ; start auto-leveling sequence
M420 S1 ; activate bed level matrix
M425 Z ; use measured Z backlash for compensation
M425 Z F0 ; turn off measured Z backlash compensation. (if activated in the quality settings, this command will automatically be ignored)
M204 S500 ; restore standard acceleration
G1 X0 Y0 Z15 F5000 ; move up off last probe point
G4 S1 ; pause
M400 ; wait for moves to finish
M117 Heating… ; progress indicator message on LCD
M109 R210 ; wait for extruder to reach printing temp
M190 R60.0 ; wait for bed to reach printing temp
G1 Z2 E0 F75 ; prime tiny bit of filament into the nozzle
M117 TAZ 6 Printing… ; progress indicator message on LCD

M221 S100 T0
G92 E0
G1 F600 E-1.75
;LAYER_COUNT:600
;LAYER:385
;MESH:NONMESH
G0 F10500 X66.678 Y126.706
G0 X66.678 Y125.271
G0 X66.68 Y115.295
;TIME_ELAPSED:62480.147795
;LAYER:385

Sorry for the mess. Site will not let me put images in yet.

Where did I go wrong?

M109 R140 seems suspect… what filament are you using?

This command tells the printer to wait for the extruder to reach 140°C … which is lower than the soften temp for most filaments. (My guess is that temp should be closer to 180°C).

Typically the printer needs to raise the nozzle temp to just slightly above the glass-transition temp for your material. E.g. if you were printing PLA with a glass-transition temp of 175°C then it would probably raise the temp to 180 … retract a bit of filament, then drop the temp to 170°C and do the “wipe” on the wiper pads … then drop to probe temp (usually 160°C) and do the bed-level.

You have all these temps set to 140°C which seems too low… and that’s why I’m wondering what material you are using. Check the material settings.

Lets look at the code from this point and after. I did not change any of the start up code.

M221 S100 T0
G92 E0
G1 F600 E-1.75
;LAYER_COUNT:600
;LAYER:385
;MESH:NONMESH
G0 F10500 X66.678 Y126.706
G0 X66.678 Y125.271
G0 X66.68 Y115.295
;TIME_ELAPSED:62480.147795
;LAYER:385

The additional error I am getting is

Print setup disabled
G-code files cannot be modified

Any help to get pass this will be great.

Here’s what that snippet of code does:

M221 S100 T0

This sets the “flow rate” for the printer to 100% flow (the normal flow rate) at extruder “0” (T0). A dual-extruder printer would have T0 and T1 … your printer only has a T0.

G92 E0

This resets the E axis (the extruder) to the “0” point. This is does so that any extrusion performed in absolute mode will be relative to that position.

G1 F600 E-1.75

This causes the printer to pull back 1.75mm of filament (it is a retraction move) at a Feedrate of 600mm per minute (10mm per second).

The next few lines are comments (anything after a semi-colon is a comment)

G0 F10500 X66.678 Y126.706

This performs a move to that X/Y coordinate position (leaving the Z height alone) at 10500mm per minute (which works out to 175mm/sec). That’s a fairly fast move and presumably a non-printing move.

But then you get two more fast non-printing moves (these are very short distances). The 3 sequential moves are basically controlling the path that the printer takes. You could just go straight to the 3rd move position and ignore the intermediary moves … but it may be doing this to move around something or follow a specific path (e.g. if “wiping” or “combing” is enabled.)

Where are you seeing this error message?