Printer stopped working after hitting cancel

I was running a print job with Cura and hit the cancel button.

The printer stopped in it’s track and then lost connection with Cura so I couldn’t move the X,Y, or Z axis. Also the temperature readings stopped showing on the Cura screen.

I tried clicking on the “Connect” button. It said “Connecting to Serial” (or something similar) then said “Closed”.

I’ve rebooted both the PC (Windows 7) running Cura and the Printer several times to no avail.

The printer is getting power. The extruder fan is running and there is LED light coming from inside the electronics box.

Any ideas?

Hmm, try a different USB port? That or grab a copy of prointerface and see if the printer will accept commands from it. Did your serial com port happen to change?

Yes, I tried a different USB port.

I’ll give Pronterface a try. Thanks for the suggestion.

As far as I know the serial comm port has not changed. How do I identify which port the printer uses?

In device manager find the arduino interface USB device, it will show there. That or the com port section

Thanks for the suggestions. Here’s is what I’ve tried:

In device manager under Ports (COM & LPT) I see:
3D Printer powered by RAMBo (COM3)

When I unplug the USB cable this device disappears and when I plug it back in it shows up.

I ran Printrun/Pronterface and set the printer to COM3.
When I click on Connect I get the message “Connecting…” and then it just hangs there.

After a few minutes I unplugged the USB cable to see if it could detect this and it did.

I’ve also tried the following:

  • A different USB Cable
  • A different computer with the RAMBo drivers installed
  • Changing the baud rate to 250,000 (as suggested in an older post)
  • Testing the 3 fuses on the mini RAMBo board

Nothing has worked so far.

I have noticed that the cooling fan for the power supply is not on, but I don’t remember if it’s on while idle so that may or may not be a symptom.

Hmm, it’s probably not your computer then, and the Rambo board wouldn’t be doing anything if it was fried. The Mini doesn’t have an LCD so it’s probably not likely that the auxiliary e-stop is tripped. There is an onboard reset button, is it possible that is pressed down somehow? It’s next to the USB port. If it isn’t that, the only thing I can think of is that somehow you wiped your rambo board. If you are under warranty you might want to call support.

Thanks again for the help.

There is nothing touching the reset button. I know exactly where it’s at.

What do you mean by the board being “wiped”? Do you mean the firmware could be gone?

Also, the USB plug was recently replaced bu the printer has been working perfectly ever since. However, if one of the leads on the USB plug has become faulty could that cause the PC to detect the board while at the same time not allowing the software to connect?

The connection speed is 115000 at most - otherwise you are communicating faster then the Arduino can talk reliably. :slight_smile:

The control board fan should ‘blip’ on during connection then stop again until the heat levels turn it on again. But no connection = no fan turning on.

Gone, or partially corrupted on the onboard ROM.

when you say USB plug was replaced, do you mean you swapped out a card on the computer side, or the port on the Rambo board itself? if you soldiered a new USB socket onto the Rambo board, something very well could have come unsoldiered due to heat.

Thanks for the tip on the fan.

The post I had read about the baud rate at:
It’s a different printer but I think it has the same mini-Rambo card. I mentioned it here so someone wouldn’t suggest a fix I’ve already tried.

The card was not swapped out. I wasn’t there but from what I understand the printer was moved and pressure on the end of the USB cable damaged the USB plug/jack. The plug on the board was then replaced.

Also, Is there a way to test the onboard ROM?