Printing pausing when monitor goes to sleep

It’s taken me a while to figure out what was going on, after many wasted spools of filament, but I’m not sure how to fix it. At one time, I found another post on this same forum but can’t find it now.

I have a print that takes about 11 hours. I’m using nGen, but that shouldn’t matter. I could print one and have it come out flawlessly. I’d set another one up to print (same model, same settings, printing immediately after last one), watch the first layer go down perfectly and go to bed. I’d wake up to a zit infested monster. I couldn’t figure it out as it made no sense. Same spool of filament, same settings, same model. Rebooting Taz and the PC in between prints yielded the same results.

One day when I was printing I left the house for about an hour and when I came back, the printer was not running smoothly. It was pausing every few seconds, and wherever it paused filament was still flowing depositing extra filament. AS SOON AS I MOVED MY MOUSE to wake the monitor up, this pausing went away and it was smooth like normal.

I have a Taz 6, using current Cura/Firmware. I do recall upgrading cura/firmware a few weeks ago, so that is probably the culprit.

I’m using windows 8.1. For my power settings, computer is set to NEVER SLEEP, and monitor is set to turn off after 1 HR of inactivity. It’s when the monitor shuts off that this problem occurs. I have not changed my computer sleep settings. It never used to be a problem printing when the monitor auto-shutoff, and it shouldn’t. I never put the actual computer to sleep - only the monitor.

Has anyone else experienced this? Is there a solution besides trying to downgrade cura/firmware? For now I just set the monitor to never turn off (via the OS) and manually turn it off when I’m done using it. That works fine and the printer works fine. I’m just lazy and don’t want to manually shut the monitor off.

The right tool for the right job – Windows desktops are for human beings, and trying to make them suitable for long-running unattended operations is a challenge. I’d suggest you look into a Raspberry Pi running octoprint instead. You can download and install a prebuilt system (“octopi”) to copy to the RPi’s SD card, plug the 3D printer into the RPi, plug in the network cable and power supply, and never worry about your Windows machine going to sleep again.

Is there any reason you can’t print from SD?

With that said… the system has been rock solid for years with hundreds of hours of unattended prints and never had this issue until the last firmware and/or cura update. Having the MONITOR auto shutoff should not cause any issue whatsoever no matter what’s going on. It’s a monitor, not the PC.

Oh, I agree with you! It SHOULDN’T cause a problem. But clearly, Microsoft changed something. And they’ve recently declared that what you thought was YOUR operating system is, in fact, THEIR service, and thus they are entitled - nay, obligated even! - to update it and change its behavior regularly – which means that even should you figure out what Microsoft did, and undo it, something like that will just happen again at some point. Hence the suggestions to avoid relying on something owned and managed by Microsoft. (Or Apple, for that matter, although they seem to be considerably less invasive when it comes to shoving OS updates onto customer-owned machines.)

If you do insist on trying to sort it out with Windows, it’s probably not the monitor. Create a custom power profile, and start turning off things like the driver-level settings that allow Windows to save power by turning off the USB chips, for example. But before you do that, I’d take a serious look at the sleep and hibernation settings – maybe the monitor is turning off because the system is shutting down into sleep mode. I know you say you’ve set it so that it never sleeps – but Microsoft has been updating your operating system, and there’s no reason to think they haven’t changed something on you - it’s at least worth checking into.

MS didn’t change anything. I don’t do automatic updates and no updates have been applied in about a year, or more.

This is primarily a Digital Audio Workstation for music production. Once you get it working, you lock it down and don’t allow things to auto change. It’s detrimental lol. Everything power saving related in bios/windows is and always has been shut off (with the exception of turning off the monitor after an hour of inactivity).

The only 2 things that changed recently that could have caused this were upgrading Cura and updating the Taz 6 Firmware at the same time (from cura).

Here’s a related post that I found earlier. I can’t look the issue up though bc code.alephobjects.com is no longer active. Issues with prints pausing after Cura and firmware update

It’s really not that big of a deal. As I said, the problem is solved by not allowing windows to shut the monitor off and I just manually shut it off when I’m done using the PC. It’s just odd to have to remember to do that. It prints fine through the night once again. Thank you for your suggestions!

Like @mwester, I use a Raspberry Pi running the “OctoPi” OS image. OctoPi is an OS image that runs on a Raspberry Pi and has an OctoPrint server built in. OctoPrint is controlled via a web browser interface. A Raspberry Pi is a small single-board-computer about the size of a deck of playing cards.

Basically you send your prints to the OctoPrint service and it controls the printer. Once you send over a job you could shut down your computer if you wanted and the Raspberry Pi will take care of everything.

Setting it up is pretty easy:

  1. Get a Raspberry Pi 4B 1GB (these things come in 1G, 2GB, and 4GB RAM sizes but 1GB is enough. I run on a Pi 3B+ (the previous generation of Pi) which are only available in 1GB RAM size. As I monitor how much RAM it is using, I still have more than half of the RAM unused. It’s very efficient. The Pi will cost about $35.

  2. You’ll also need a 5v / 3a power supply ($8) and a microSD card. An 8GB card would technically be big enough but … I was at Micro-Center and discovered they don’t even bother to stock anything smaller than a 32GB card and even the top performing cards in that size were less than $15).

  3. You would also need a case (Raspberry Pi doesn’t come with a case). The official Raspberry Pi case is $8. But most people who own 3D printers just print their own case … because you can make something that mounts to the printer.

  4. Optionally you can add a camera. The official Raspberry Pi color camera is pretty good and it’s $25. OctoPrint also supports a pretty long list of USB web-cams. This lets you look at the printer to make sure it isn’t making pasta.

There are dozens of “how to set up OctoPi” videos on YouTube. It takes about 5 minutes to have everything working because it mostly self-configures the first time it boots (it creates a web server on the Raspberry Pi and when you connect to it with your browser, it walks you through a few tasks such creating your admin account and setting a password, etc.).

Once it’s set up, you’ll go into the OctoPrint settings panel (it has a wrench icon) and pick the “API” category. This is a key used to secure API access. There’s a really nice Cura integration to OctoPrint but it needs to know this key. So you copy the key, then on your PC/Mac in Cura, you’ll go into the Printer settings and find the option that says “Connect to OctoPrint”. You paste the key there.

IF your computer has Bonjour (all macs have it built-in. Windows traditionally did not have it built-in and you had to install Bonjour for Windows … or install iTunes for Windows and it includes Bonjour). I’ve “heard” that Windows 10 now has it but have not been able to confirm this. If you don’t have Bonjour you’ll need to find the IP address of the Raspberry Pi.

Bonjour is a zero-configuration protocol. You don’t need to know the name or IP address of the Raspberry Pi if you have Bonjour. Cura will broadcast that it’s looking for the service and the Pi will auto-respond to the request and self-configure (it really that easy). So really you only need to know the API key. If you have any Apple device (mac, iPhone, iPad, etc.) they all have Bonjour built-in. E.g. if you use the browser on your phone to visit “octopi.local” it will work as long as you are on the same network as your Raspberry Pi.

Once that is set up, you’ll notice that where you previously had a “Print” button in Cura, it is replaced with “Print with OctoPrint”. And when you go into the “Monitor” panel in Cura, you’ll notice you can actually SEE what the printer is doing (it shows you the video feed from the camera) and you can remotely control the printer. It’s really nice.

I use it because I usually have my iPad with me and I can look in on the printer from anywhere. I have a VPN into my home network so I can even check on my printer when I’m away.