TAZ Workhorse - Failure on First Print

I tried to print the octo gear on a new TAZ Workhorse. It got to 63% and then just … stopped. I’m not sure what happened. There were no error messages, the head just stopped moving. Cura said that the connection had closed, do I have to keep my computer awake for printing to succeed? I think the fan might’ve been running at 100%, I dunno if that’s a problem. This was with the default PLA that came with the printer.

Any ideas?

FYI, these statements are contradictory. “no error messages” “Cura said that the connection had closed”

“Connection closed” would seem to indicate USB cable, connectors lost connection or your ~ maybe your computer may have restarted in the middle of the print.

Try again or maybe print directly from SD card.

Thanks for your reply, Edge. The computer didn’t restart – it might’ve gone to sleep, though. I’ll give it another shot…

I’m pretty sure (99%) that the computer going to sleep is the problem. There are other “Windows behaviors” that can interrupt 3D printing. Windows is not and was never intended to be a real-time operating system.

I solved this problem by purchasing a Raspberry Pi for $35 (plus a proper power supply and case) and installed OctoPrint on it.

Thanks, b-morgan. I tried it again, this time not letting the computer (macOS) fall asleep, and it worked fine. Getting it off the bed was a little tricky, but definitely an improvement!

The computer feeds the printer’s buffer just a few instructions at a time (not the whole job) … so the computer does need to be awake the entire time.

If you print via the SDcard slot then no computer is needed … the printer is independent.

Another option is to get a Raspberry Pi and install OctoPi https://octoprint.org The Raspberry Pi becomes a remote print-server and, as a bonus, your computer and printer don’t need to be in the same room. My printer is in a utility room but my computer is in my office.