Stepper Motor Failure?

I sent an email to support but I like to know if anyone here know a solution. The stepper motor on one side of the mini malfunctioned today during a 4 hour print. I include a link to a video showing that a cylindrical piece of metal attached to the stepper motor is slipping. I’m sorry, I’m new to 3D printing so I do not know the terminology.

Take a look at this short video clip:

And some images here of the failed print.

What’s the best way to solve this?

You can tighten that piece yourself with a hex key. I think its two screws near the bottom and two on the top, since the bottom is spinning it looks like that part is loose.

Contact support on Monday at or 970-377-1111 and we can get it fixed/replaced for you.

Sorry about the inconvenience,


Exactly the same thing has happened to my Luzbot Mini. Only used the printer 4 times.

Thank you Keebie81, I fixed it last night by tightening the two screws. Surprisingly, both side of the threaded rod had loose screws. It was an easy fix and now it is printing normally. I will have to do a long print to see if there are any further problems.

Awesome, glad it worked

I may be facing this same issue, can someone describe exactly which screws to tighten? :question:

It happened to me to. It skewed my Z axis really badly too since one side was moving and the other was slipping. Turn the shafts manually by hand until they top out at the top of the shafts and tighten the couplers back down. This ensures the whole Z axis is semi-level. Should fix it.