Stepper Motors Not Working

I have been a long time lurker on this forum (got my taz over a year ago) and this is the first major issue I have had. I turned on my TAZ4 today and tried to print out a new part and none of the motors seem to be working (X, Y, Z, and Extruder). After preheating my taz for abs I selected my print, however, nothing moved but I could see the progression of the g-code coordinates on the lcd screen. I then stopped the print and tried to print out a part i had previously printed (assuming the g-code was somehow bad) and that too had no movement. I then tried to manual move the motors through the printer itself and it too had no movement. I assume that i have blown a fuse on the rambo board somewhere. However, I don’t know where to look to solve this issue.

It sounds like you may have blown a fuse on the RAMBo board. You may want to check the F2 specifically as it controls motor function.

If the F2 fuse has been blown, you can find replacements here.

I hope this helps!

Thank you for the quick reply! After a quick check the fuse is indeed dead. Hopefully i can get it back up and running shortly.

So i got the replacement fuses in today and after replacing the fuse the motors still refuse to do anything. Any thoughts?

Hmm, a couple of items you can check will be the power supply, and the firmware. Try to reflash your firmware following this guide:

If you have access to a multimeter, you can also double check your PSU’s output. Pins 1 and 3 will be grounds, while pins 2 and 4 will be live. Any combination of positive and negative pins should give you a +/- 24v DC.

Unfortunately, if it is not the firmware or the PSU it will most likely point to an issue with the RAMBo board itself.

make sure you didn’t accidentally pull the fues contact plates out of the socket when you removed the fuse. It’s pretty easy to do on accident, and you won’t like the fix.

I hate to bring this up but fuses usually don’t blow all by themselves. If you didn’t trace down the short that caused the initial blown fuse, the new fuse has probably also blown.

The 2 different fuse blowing scenarios that I have experienced are a short (in my case at the extruder connector. (Self inflicted wound. :blush: )

The second fuse blowing scenario was a bad power filter capacitor. Is the top of the large capacitor just above the F2 fuse bulging out? If so, you may have a bad capacitor.

I haven’t touched the firmware since i got the machine so i don’t see how that could mess up but ill give that a go later. As for the fuse contact it isn’t making great contact with the housing compared to the other fuse, however, even with pressing the fuse harder into the socket using a piece of rubber it still doesn’t make a difference. As far as i can tell the capacitor looks fine (nothing on the board seems damaged or out of place). I tested the new fuse again and it is still working and hasn’t blown. As for testing the power supply, do you mean testing the power as it is coming from the power box or as it is going to the board itself? P.S. Sorry I am not great with electronics.

The pins Brent talked about would be the ones on the end of the power cable that plugs into the control box of the printer.

Hi, I’m having the same problem. Fuses are working as intended, power is 24VDC, nothing blown or off on the board, and the screen is doing the same thing where it shows the motors moving on the axis, but they fail to actually move. I’ve replaced the Rambo, but oddly enough I get a blank blue LCD screen with the new Rambo board. I’m at a loss. Any help?

Have you flashed firmware on to the new RAMBo board yet? That will need to be done before the board will be fully functional and able to run your printer properly.

You will need to flash the firmware after installing a new Rambo.