TaZ 4 Z axis height issues

I am looking for some community input as I have basically exhausted all my known resources to fix this issue.

Ok so i printed 3 versions of the Rocktopus.

here were my steps so you can follow along and help out because i know there is an issue somewhere.

  1. i downloaded your model above
  2. i went into Cura 15.02.1-1.03 and in the menu went to expert switch to quick print and choose fast.

saved this as gcode and put it on the SD card to put into printer
pre heated printer to 230 ABS and 105 bed. 105 is the only temperature so far I can get proper adhesion.

started my first print.

  1. the first one. the bottom layer didn’t adhere as well so it failed when one arm popped off the bed so I stopped the print. otherwise it looked to have great adhesion on first layer.

next i said let me download the Cura profile so i went to here to get the right profile.




i choose

TAZ ABS Profiles
TAZ 1-4 Recommended Temperatures: Extruder: 230°C Bed: 85°C Part Removal: 50°C


and downloaded the fast profile

Fast, 0.28 mm layers


then in Cura i opened profile.

then i re saved the G-Code to the SD card and printed again.


this third print did as well print.


here is where the wheels fall off.


I opened the rocktopus_v1.9 inside of Netfabb to get the exact dimensions so i can check compared to the real print it shows me that length is 146.57 width is 148 and height is 47.17.

I will come back to this a bit later.


This was print 1 and how it failed - that’s ok prints fail although i am not quite sure why it failed.

Print #2. completed but didn’t look right. in the Z axis

Print #3. completed again looked even worse, I assume it was because it was on fast. but the Z layer height was still not quite there.

Using part 2 and 3. I started to measure it compared to size i saw in netfabb above.

X accuracy is right on.


Y accuracy is right on.

Z height however. is off by almost 50%

Netfabb says that the model should be 47.17mm tall.

Z height for #2 is about 20 MM


this is print #3 height it comes to about 22mm

top view of #3


Top view of #2


Bottom Bed adhesion of #3

Bottom Bed adhesion of #2


failed print #1 bed adhesion

I have re flashed my firmware to the TAZ 4 single extruder, adjusted my E steps based on https://ohai-kit.alephobjects.com/project/extruder_calibration/

I moved the Estep value from 1140 to 879.7 based on what was in the tutorial.

I made a mark at 120 and it leave 20 out

Hope all this information helps.

The Taz 4 has supported Leadscrews top and bottom on the Z axis. The Taz 3 and below has a threaded rod supported at the motor. The thread pitch is significantly different between the two machines. You either have a Taz 3 with Taz 4 firmware on it, or a Taz 4 with Taz 3 firmware on it. If you want to post a picture of your whole printer I can tell you which one for certain. If it ends up you have a Taz 4, and you reloaded it with what should be a Taz 4 firmware, let the lulzbot peoples know exactly where you downloaded it from. it’s possible there is a firmware somewhere with an incorrect value.

That specific issue is pretty much only caused by Firmware not matching the hardware. It’s theoretically possible it could be 2 loose motor cables as well on one specific pin, but that would be highly unlikely.

Thanks, I downloaded the firmware from here

TAZ 4:
TAZ 4 Single Extruder, Budaschnozzle


Thats definitly a Taz 4. Which specific firmware link inside that page did you use?

I’ll have to check my Z-steps value for you when i get home and let you know what it should be. Unless someone else gets a chance to do that first. You may want to give support a call. If the value is truely wrong for some reason, they might be able to get you back up and running quickly.

here are my current settings.

Your Z steps should be 1600 if you have Taz 4 firmware loaded. So, either that copy of the firmware is wrong, or you somehow have all or part of a 3 firmware compilation loaded.

Have you verified that your controller box fan has not come loose, and no wires are obstructing it? The Z stepper driver controls two stepper motors, while the X,Y,E only control one. If your controller box is overheating, the Z axis will be the first place to show signs. (Location of fan plug in, last step here.)

If you would like, you can plug your CB fan into a direct 24v connector on the board. (This will have your fan run at full speed whenever your printer is powered on.) There are two unused pins on the top left corner of the RAMBo board. Remove the 2pin molex connector from the board for the 80mm fan, and plug it onto these pins with the red wire up.

I hope this helps!

Yes talking to support we verified the fan on the side of the box comes on. When I hit Auto home, it turns on and runs. I also can install some Scythe-3000s on the side if i need to. or worse comes to worse i have server fans i can use that sound like jet engines i can mount on the side if it becomes a heat issue.

where in the documentation does it give the average measurements per firmware with the specific load?

I can set it to 1600 but I want to understand what that means before I start messing things.

what other values work with the Z axis

Z-offset - 0
VZ-jerk - 000.40
Vmax Z - 3
Amax Z - 100

I just double check the firmware flashing guide, and you may have downloaded the incorrect file. TAZ 4 Budaschnozzle file should be Marlin_taz_4.1_revb.cpp.hex

We used the 800 steps/mm in our TAZ 1-3 models, as they had a different Z axis drive rod.

I certainly downloaded the right firmware based on last statement

Marlin_taz_4.1_revb.cpp.hex

I went ahead and modified my

ZSteps from 800 to 1600 and i am currently in the process of trying to print again to see what happens. I would like some clarification as the difference between the numbers and why they are the values they are.

Z steps per milimeter is a measurement of how many motor steps it takes to move the motion axis 1 milimeter. Under the Taz 3 and below, the threaded rod actual thread pitch and rod diameter is significantly different than the thread pitch and rod diameter of the leadscrew. The motor is the same. In order to move the more accurate leadscrew axis 1mm, you have to turn it twice as far (mainly because the rod is much wider), hence the larger number. That is set inside the configuration.h firmware file inside the firmware package itself. Your firmware was showing 4.1, but it has the old value. Which is wierd. But someone else ran into that same issue in the forum. they fixed it by uploading a different firmware. My guess is that at least one of those downloadable firmware packages for 4.1 on Cura has an incorrect value in it somewhere. Not many people are going to upgrade the firmware on a 4, and Cura was introduced more towards the 5 so probably not a whole lot of 4 owners are using it.

I am normally not one to get hysterical and say Success! but in this case I’ll take it. all I did was change the Z Esteps value to 1600 and I got this print
20150903_162100[1].jpg
You may wonder why this is such a happy moment, and that is because i can now finally stop wasting literally pounds of filament.

now i would like to get a RCA of this so how can i have had the value 800 in that setting if the firmware was flashed from a known good firmware on the site?

Does the firmware not change these values by default?

Updating the firmware on a 3d printer using an Arduino based controller, such as the TAZ ends up writing a series of files to the actual onboard arduino chip. One of those files is called configuration.h, and it contains the step values. When you flash your firmware, that file with the new values is transferred to the printer controller. The only things I can think of in this instance are either “the firmware had an incorrect value” or somehow the incorrect values ended up in the printer. It’s possible that Cura writes them directly and maybe it wrote the wrong value inadvertently after flashing? I can’t open the .hex file from here, so I can’t see what it has embedded in it for a default.

I usually update my firmware via the arduino updater anyways. But that’s mostly because I tinker with mine a lot.