Taz 4 Z axis wont move.

Just got our Taz 4 out of the box, set up and printing in an hour. Did two print last night, all was well. This morning when starting up a new job I noticed the Z axis being a bit off, filament not holding to the base, so I did the Z axis stop adjustment as outlined in the setup guide. I think I might have dialed it down a bit too much. When I homed it after doing the adjustment the Z axis motors gave off a less than happy grrr and all motion on that axis stopped with the head being on the glass. I tried to raise the Z axis, nada but the grrrrr sounds.

And so I come before you, newb hat in hand…what be the fix to get the dang thing off its arse.

Thanks in advance.


Are you using Pronterface to interact with motors? Or are you trying to use the little screen on the TAZ itself?

There’s no movement when trying to raise the z axis off the glass bed? :open_mouth:
Is your z-axis stop switch compressed at this point?

If I was in your shoes I’d remove the extruder head first. One bolt.
Then I’d remove the glass bed. 4 bolts. . Replace extruder head, then see if I could “home the z-axis” without the glass bed installed. At the very least I’d hope at this point I could raise the extruder head up.

WARNING - I am not an expert- so perhaps wait for somebody else to comment. :blush:

I have been using the Rambo compy that came with the unit. One of the selling points for me was having a self contained system without need of another computer attached. Up until I munged with the Z Axis Stop I was able to do everything from the Rambo panel. Hats of to the designers of that, great easy interface.

I like your idea for taking off the extruder head, would make me much happier not having it jammed up against the bed any longer. I will give that a shot. thanks

I took a head off with no problem. I then tried to move the z-axis from the front panel controls and it is still just making the bad sounds and no motoin is seen. I also checked to make sure the switch was not activated, it is clear.

The plus side of this is a cleaning of the nozzle. The down side, still.no z axis motoin.


Hm, that’s not normal. With the motors turned off, is it easy to turn the z-screw by hand? If not, you might need to check the alignment of the x-ends. If they are easy to turn, then it is possible that there is a wiring issue, and you should check the harness between the board and the motor for loose crimps. There is also an updated firmware that increases the current to the motors to give them more torque to power through any extra friction, although I think new TAZ ship with that version flashed.