Taz 5 problem

I’m not sure if this is the right place to post this, but luzbot support hasn’t been able to help. When homing all axis (either from cura, sending g28, or from the printer itself), the printer will just start to move the x axis, then the LCD will start flashing between all white, all blue, and some random lines (best I can describe it as “glitching out”) with a clicking noise. The printer stops everything and needs to be reset by flipping ouit off and on again. I first tried unplugging the x axis stepper motor and this allowed y and z to home. So I ordered a new stepper thinking something was shorting out. The new motor didn’t fix the problem. Then I talked to support. They had me update cura and update firmware. Still didn’t fix it. Testing with m119 showed all my endstops were fine. Then, out of boredom, I tried moving the x axis manually (through cura) without homing anything. To my amazement, it worked! I left the extruder almost at x home and sent the g28 command. The x axis homed, and this time it glitched out while moving the z axis. Unplugging the x motor still allows y and z to home, but I can move x, so I’m really confused. I can post a link toa video if needed. Does anyone have any more ideas?

Power supply?

The LCD sounds like a supply re-start condition.

I can try troubleshooting the power supply. Although I can leave the machine on, and move axis, it just glitches when homing all axis.

It draws more power when homing as it does fast moves during the homing operation, but not while doing manual moves. That is why binding is seen more during homing operations than manual moves.