TAZ 5 Stops Mid-Print

I have had several instances where our TAZ 5 just stops in the middle of a print. No error message. Just stops. Holds temperature. LCD display responds.

Sometimes I think it is the machine. I reboot and retry the print and it is successful, but not always.

Sometimes I think it is the gcode. I regenerate and save the code and it works. I believe I have experienced this both in Cura and in Simplify3D (which I really like).

Has anyone else noticed this?

I have this problem from time to time. Octoprint usually says “fatal error.” It has never been repeatable so, I have no idea why it happens. It is not the gcode, I can run the same gcode on the same printer or another printer without error following the failure. It has happened on my modified Taz 2 as well as a stock Taz 5. I have never seen it on the Mini.

All of my printers and controllers are on UPS so, I don’t think it is a voltage problem. I have always assumed a random communication problem but, that is just a guess.

Post back if you happen to figure it out!

Interesting. LulzBot support has asked me to look into two things.

One, they say it might be the SD Card. But you have experienced this printing over USB. I will get another card and try anyway.

Two, they say the stl file has too many shells and the slicer, Simplify3D, cannot generate appropriate code to tell the print head where to move. Yet I have successfully used that stl before and the slicer gives no error. The code doesn’t abruptly stop. Their simulation completes.

I don’t think a bad stl is the problem in my case since I can run the same gcode without issue following the failure. Even on the same machine.

I also get the “fatal error” in Octoprint. Luckily, its usually when I start a print… only once did it happen during a print. When the error pops up, Octoprint restarts and I can try the print (usually successfully) again. There is an advanced setting deep in one of the setup menus, which tells Octoprint to ignore and continue sending g-code… I haven’t tried the setting because it doesn’t happen that often and not sure where the gcode goes while the TAZ is rebooting… which seems to be pretty quick.

I think its a bug in the Marlin code… Newer builds may resolve the issue.

How does one know if a more recent version of firmware is available?

Good to know I am not the only one that suffers with this. My failures are never when I start a print but always early in the print.

I have had the same problem four times know. USB only. SD Card works fine. I reported it but no help via Lulzbot.

So others are having the problem too, both on USB and on SD. May I ask what slicer generates your gcode? Are you using Cura or something else. I’m on Simplify3D.

You refer to the “fatal error” on octoprint. I am not familiar with octoprint. And you actually get an error message? I get no message. It just stops moving.

I am currently printing a model that did not give any errors, but the printer would just stop at points in the print. I ran it through a on-line model repair and it looks to now be close to finishing or at least a lot farther along than it has ever gotten before. No errors or a GCode file generation does not mean there is not something wrong with the generated file that the printer firmware can not handle.

Octoprint is Web based printer control software that can run on small computers like the raspberry pi.

The prints I have problems with are sliced by Slic3r.

If I understand you correctly, just because a slicer can generate code, that doesn’t guarantee the printer can execute it? So it just hangs??

I think a bad/open polygons/surface generates commands the firmware does not know how to perform, so it sits there trying to figure out what to do with it.

If that is true, doesn’t that represent a real software oversight? The slice knows what machine you have, and it even has a simulator. Why would it not detect the problem? And shouldn’t the LulzBot at least give meaningful error message, instead of just stopping?

I’ve successfully gotten off other prints with the same stl. So no idea why it intermittently occurs.


I’ve had the exact same issue that you’ve had with USB printing. I first noticed it when using my octopi setup and then continued to notice it with connecting directly to my computer. Prints would start just fine and after a few hours, or even a few minutes, they would sometimes just fail. The print head would stop moving, the temperature would hold steady, and everything would just stop. Then, sometimes it would run a 20 hour print just fine. It turns out that the problem was an interruption in the USB connection. I’m still not sure if it’s just a bad cable or bad port on the printer.

My solution so far has been to just slice in Cura, save to a SD card, and print from the SD. I’ve now gone through multiple 20+ hour prints with no issue when I used to have failures fairly frequently.

Also, I’ve found simplify3d to be kind of hit or miss for me with leaving random holes in models. Not sure if it’s the model, the program, or user error. It’s great for some things, but I generally rely on Cura.

Interesting that we have the same symptoms, but differing circumstances. Mine is not usb, but sd only. And I believe I’ve experienced it in cura and s3d. At this point I don’t think anyone knows what’s happening.

Then it’s probably a communication problem like mine. I’d swap to a better SD card because they’re not all created equal and check my wiring connections.

I have had this problem recur on a different machine, different stl, different gcode, different sd card. I am hard pressed to say this is anything but a software/hardware issue on the lulzbot.

I have had this happen a few times as well printing over usb on my taz 5 as i have never printed with sd card. no errors heatbed and extruder hold temp. and could reset it and print the same part all the way through just fine so wouldnt be a gcode error or you would get it everytime trying to print that same part. has anyone figured this issue out yet?