printing stops mid print

my printer will sometimes (not all the time) just stop printing about 3/4 of the way through a print and sit there with the heated bed and hotend running. I am running the print off of the SD card in the lcd and have checked all of the harness leads, they are good, checked the g-code, appears to be good, and the print stops without the status on the screen changing. I try going into the options and telling the print to pause and then resume, hoping this would shake it loose from whatever funk it has itself in, but no luck. any ideas?

Are you printing from the SD card or from software? If software, make sure your PC is not going to sleep or hibernating…

I have also seen this several times.

I have seen it using a raspberry pi with octoprint - which I’m sure isn’t going to sleep, and I have seen it printing from the SD card.

So is this a TAZ 5 or a homebrew project? Have you tried another file?

I was printing form an SD card on the LCD, this is a KitTaz that I am printing on.

Were you able to figure this issue out?


I did not really figure it out, I went around it. I hooked up a Raspberry Pi to the printer and send G-code to it after slicing on my laptop. the Pi is running Astroprint. If I had to make a guess as to what is wrong though, I would say that I have an intermittent failure in one of the crimps I did for the LCD Screen (there was no harness available so I made one), so even though the print will run fine for hours it will fail after one of the crimps jiggles loose for just a split second, but long enough to interrupt the signal to the printer board.

This happened twice for me, once on laptop to TAZ the other from SD to TAZ. I have mine on a sag fighter/Battery Backup system, so I don’t think it is power related.

The LCD would say stilling printing and all heat is on, bed and hot end. I have not called Lulzbot about it yet because thought it was the gcode causing the issue. I have pictures but not sure how to upload here.

**EDIT Using CURA 17 that came with my TAZ 5 about two months ago.

This has happened to me about 4 times on my new TAZ 5 printing directly from the SD card. Twice it was the same gcode file where I tried again just in case. This TAZ is only about 3 weeks old, and is running 2015Q3 firmware, and the model was sliced with Lulz Cura 18.03.

The latest crash was last night, halfway through a print of the LFS Elephant from Thingiverse,, small version scaled up x1.1, and printed with mostly default ABS settings. It got to about 12.8mm or 64 layers before it quit.

I have uploaded the ~10MB gcode file. Would anybody be willing to try to duplicate the problem with it? Or read the 300k lines of gcode :laughing: ?
LFS_Elephant.gcode (9.31 MB)

  • cquinn they will look at your gcode for you if you email them. I am going to send mine tonight when I get home.

I just got an email back from Lulzbot Help Desk :

They replied with the following

""Manifold is the property of an STL model where every surface is completely closed. Sometimes if an STL is not manifold, the slicing engine will create a gcode, but weird things happen when the printer tries to run that gcode. It sounds to me like this is not the issue. Don’t worry about the calibration octopus, if you know you can successfully complete a print.

A couple possibilities:

  • Computer/Rambo communication interruption
    This can be caused by some computer’s energy settings, some background software kicking in (such as anti-virus), or some one-off glitch in communication. This would only occur through USB controlled prints.

-Electro-static discharge (ESD)
On occasion, a static charge can be sufficient to stop a print. This is well known. Consider your printer’s location, and whenever possible, avoid touching the printer during a print, to reduce this possibility.

-Bad SD card
Even if the file seems to load and run, it’s possible there is some corruption in the SD card interfering with things. If the issue persists, try another card.

I suspect your 2 mid-print stopping events are some combination of some of these interruptions, and are likely both one-off issues. Under normal circumstances, there is no fix that will prevent these possibilities from arising, but they should not be pervasive, by any means.""

Since my failures were during an SD card print, that rules out the ‘Computer/Rambo communication interruption’ case. The printer was sitting on the floor in the middle of an empty room during the night and no one was nearby. I think that’d rule out the ESD. Maybe a bad SD card, but this is the one that came with the TAZ…

I’m more likely to believe the bad STL / slicer combo. In one of my failure cases, I scaled the print up a little and re-sliced, and that succeeded. Although… a robust gcode interpreter shouldn’t crash on any input. Just sayin’ :wink:

I’ll mail Lulzbot and see what they say.

After four months and various prints, I just started having this problem on a print last night and then again this morning.

Printing from SD card, two different G-Code files (Same design, one solid, one split into two halves and shrunk 20%).

First one froze halfway through, and the second froze during the first layer.

I noticed I was using Cura 17.10 and have since updated to 18.03. Printing right now, hopefully this solves it.

…else I’m going to check firmware and try a different SD card.

I played around with a combination of better power source (no power strip), new SD card and same .gcode file, and the print was successful. So that eliminated the actual model, slicing, gcode firmware handling.

Then I did a “First Aid” pass on the SD and it was pretty messed up. My guess is that I failed to eject it properly one or more times and corrupted the FAT filesystem in a way that impacted the TAZ firmware more than my Mac.

So, I really recommend trying a new and known-good SD card for anyone having this problem.

SD card files corrupted, won’t a re-format take care of it? I was going to say, even if your printing from a SD card, leaving the computer connected with a USB connection can cause a problem IF the computer goes to sleep or does a Microsoft Update while printing.

My 4 hour print completed successfully from the same SD card but using Cura 18.03 generated G-Code. Computer not attached to Taz with USB.

If I run into this problem again I’ll be sure to post in the topic.

I’ve had my Lulzbot mini for almost two years and “just” starting seeing this symptom. I use it tethered USB to my iMac, so no USB card problems. I find that if I shut everything down and restart Cura, it will do fine the 2nd attempt. Why I haven’t figured out exactly what causes it, I find that if I try to re-print something or load another print without re-starting cura this will increase my chances of the symptom occurring. On 4hour+ prints, its worth the restarting insurance policy.
I suspect something on my iMac is triggerring the pause, but it’s more of a locked up Cura software than a sliced file or hardware issue.
If anyone figures out a specific incompatible software, please share.