TAZ 5 "Z" scaling issue

Not only do I have an excessive “Y” scaling (125%), but I also have a “Z” scaling issue (65%). Only the “X” value is correct on my prints.

I tried re-flashing the firmware from an ancient version, but with only the dual extruder available, it reverses the extrude - so extrude retracts and retract extrudes. I also tried an earlier firmware for dual extrusion along with the last 3 releases. No change.

I’m left with only 1 solution; scale the model by 84% in “Y” and 162% in “Z”.

This really sucks!!!

I have spent over 100 hours trying everything from software, firmware, to hardware - I’ve replaced the RAMBo, the LCD, the Bed bearings, the “Y” stepper motor, the “Y” stop switch, along with using an old version of Cura (15), newer versions of Cura (3.2.23 & 3.2.32), and Simplify 3D (last year’s version and this year’s version) ALL without any success.

I contacted Lulzbot to try and get all new internal controller wiring harnesses, but they said they didn’t have them.
I can’t imagine anything else that may affect this Y and Z scaling issue…

Is there someone out there that has encountered this, and if so, discovered a solution they would be willing to share with me?

Kind regards,

Go into your console and type M501 . That should return a bunch of lines of text in the console. Look for and find the one that looks like “echo: M92 X__ Y__ Z___ E__.” . For a Taz 5 they should be X100.50 Y100.50 Z1600.00 and then something different for E. If those numbers are correct its not firmware. You’ve replaced most of the things that it would be if it isn’t firmware though. If those numbers are correct, and you print one of the models preloaded on the SD card to the printer without it connected to the computer and it still scales incorrectly, Either your Rambo is bad, ( a short to the motor controller chip for that axis, or a failed mosfet) or the harness / motor / mechanicals are bad. Z scaling on Both motors would indicate that you have the wrong Z axis value, probably the threaded rod value from the Taz 3 or earlier which is different than the taz 4-6.

With the printer online, move the bed with the LCD. Then try and push it lightly with your fingers. It should be difficult to move. If it moves easily, your Y axis motor is not fully powered (one of the 2 coils may not be getting power) or has a coil reversed in polarity. If you hear a thumping sound it may be a belt too loose.

If you want to source the wiring harnesses, itworks3d.com or building your own are the only two routes available. Some of the ones from itworks aren’t available as well.

The Taz Rambo board is a fairly simple device at the heart of it. If it is functioning properly and you tell the Y axis to move 10mm, and Y steps is set to 100.5 steps per unit, its going to move 1005 steps and then stop. No more, no less. If the mosfet or the controller chip for the Y axis is damaged it can apply more or less voltage than you sent and move it more or less steps. If the harness is damaged and only half of the motor coils are engaged it is possible that it will move less than 100%. If one coil is reversed it will either not move at all, or move double the expected amount.

Its not your power supply, the LCD would be behaving oddly or all of the axis would be having issues. Its probably not the LCD, they usually fail to graphics issues, it plays no role in control movements once the file is handed to the Rambo board.

Where did you source the Rambo replacement from? was it a used one? any chance it got shocked when it was installed or has a screw sitting behind it, or a heat sink fell off and is shorting to the board? What you are describing still would indicate a failed Rambo to me if it is also printing incorrectly from the SD card. Download some gcode from download.lulzbot.com if you don’t have the original files anymore, don’t use one you sliced with your slicer software as it could also be the issue here.

If it were me, i’d take the control box apart, check it for metal debris or anything that might be causing a short, then reassemble it step by step using the ohai diagrams, and if that doesn’t work, then replace the board again.

Thanks for the comprehensive diagnostic process.
Yes M501 returns the correct values for X,Y,and Z.
The unit functioned correctly for about 3 months when the Y and Z axes went off. That’s why I replaced the RAMBo. Hard to believe that the new board does the same thing the old one did. This makes me think your suggestion of wiring is probably the culprit.

One more piece of information that may lead me to believe the wiring is at fault: In order to get good results from printing ABS, I created an insulated enclosure and inserted a heat lamp to raise the ambient temperature to 160F. This worked very well; no more warped ABS parts. But… maybe all of that heat damaged the wiring to such an extent that it induced excessive resistance.

So with no harnesses available, I guess I’ll have to make my own:(

I wonder if Lulzbot has a wiring harness diagram available?

Kind regards,

The wiring diagrams are in Devel.lulzbot.com and download.lulzbot.com Ohai kit also has some. If you can’t find suitable ones, you can use the Taz 6 cables as a loose guideline. They add a couple of wires for the auto sensing.

You mention you have your printer in an enclosure. Is it a vented enclosure that provides cold air to the control box fan? If not, its quite possible the motor chip melted on the first use.

You can test the wires using a multimeter. Set it to check for continuity and check all 4 pins from motor end to board end. If those read good, the harness is fine.

The Thermal protection on the driver chips kicks in at about 95F so you will get bad results if your control box is pulling in that hot of air temp.